summaryrefslogtreecommitdiffstats
path: root/hl/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-03-21 14:19:09 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-03-21 14:19:09 (GMT)
commit0596de6267e6917057df2ebe2f7e524a1a9e6773 (patch)
treec9067bc08c7ed74bee33da7b6ec6063ef69df156 /hl/test/CMakeLists.txt
parente7ced517bc9fab1e13962231e53ef5c107daf88e (diff)
downloadhdf5-0596de6267e6917057df2ebe2f7e524a1a9e6773.zip
hdf5-0596de6267e6917057df2ebe2f7e524a1a9e6773.tar.gz
hdf5-0596de6267e6917057df2ebe2f7e524a1a9e6773.tar.bz2
[svn-r23412] Add test depends on clear test. Occasional failures.
Diffstat (limited to 'hl/test/CMakeLists.txt')
-rw-r--r--hl/test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/hl/test/CMakeLists.txt b/hl/test/CMakeLists.txt
index 39a3811..c5b6f6e 100644
--- a/hl/test/CMakeLists.txt
+++ b/hl/test/CMakeLists.txt
@@ -31,6 +31,9 @@ MACRO (HL_ADD_TEST hl_name files)
SET_TARGET_PROPERTIES (hl_${hl_name} PROPERTIES FOLDER test/hl)
ADD_TEST (NAME hl_${hl_name} COMMAND $<TARGET_FILE:hl_${hl_name}>)
+ IF (NOT "${last_test}" STREQUAL "")
+ SET_TESTS_PROPERTIES (hl_${hl_name} PROPERTIES DEPENDS ${last_test})
+ ENDIF (NOT "${last_test}" STREQUAL "")
# --------------------------------------------------------------------
#-- Copy the necessary files.
@@ -75,6 +78,10 @@ ADD_TEST (
test_packet_table.h5
test_table.h5
)
+IF (NOT "${last_test}" STREQUAL "")
+ SET_TESTS_PROPERTIES (hl_test-clear-objects PROPERTIES DEPENDS ${last_test})
+ENDIF (NOT "${last_test}" STREQUAL "")
+SET (last_test "hl_test-clear-objects")
HL_ADD_TEST (test_ds "dsdata.txt;dslat.txt;dslon.txt;test_ds_be.h5;test_ds_le.h5")
HL_ADD_TEST (test_dset_opt "")