summaryrefslogtreecommitdiffstats
path: root/hl/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-05-13 16:01:50 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-05-13 16:01:50 (GMT)
commitae06433ab0ca13838c2762c8fad165a041d64c42 (patch)
tree72d645731c00953c3daf6dad8a1cf0dc97326943 /hl/test/CMakeLists.txt
parent940931aa853602b0b6edfd4ca1a6526fd7975dd2 (diff)
downloadhdf5-ae06433ab0ca13838c2762c8fad165a041d64c42.zip
hdf5-ae06433ab0ca13838c2762c8fad165a041d64c42.tar.gz
hdf5-ae06433ab0ca13838c2762c8fad165a041d64c42.tar.bz2
[svn-r18793] Add files to support building library with CMake
Tested: Local linux
Diffstat (limited to 'hl/test/CMakeLists.txt')
-rw-r--r--hl/test/CMakeLists.txt67
1 files changed, 67 insertions, 0 deletions
diff --git a/hl/test/CMakeLists.txt b/hl/test/CMakeLists.txt
new file mode 100644
index 0000000..8397417
--- /dev/null
+++ b/hl/test/CMakeLists.txt
@@ -0,0 +1,67 @@
+cmake_minimum_required (VERSION 2.8)
+# --------------------------------------------------------------------
+# Notes: When creating unit test executables they should be prefixed
+# with "hl_". This allows for easier filtering of the test suite when
+# using ctest. An example would be
+# ctest -R hl_
+# which would only run the High Level based unit tests.
+# --------------------------------------------------------------------
+
+PROJECT (HDF5_HL_TEST)
+
+#-----------------------------------------------------------------------------
+# Generate the H5srcdir_str.h file containing user settings needed by compilation
+#-----------------------------------------------------------------------------
+SET (srcdir ${CMAKE_CURRENT_SOURCE_DIR})
+CONFIGURE_FILE (${HDF5_HL_TEST_SOURCE_DIR}/H5srcdir_str.h.in H5srcdir_str.h @ONLY)
+
+INCLUDE_DIRECTORIES (${CMAKE_CURRENT_BINARY_DIR})
+INCLUDE_DIRECTORIES (${HDF5_TEST_SOURCE_DIR})
+
+# --------------------------------------------------------------------
+# Macro used to add a unit test
+# --------------------------------------------------------------------
+MACRO (HL_ADD_TEST hl_name files)
+ ADD_EXECUTABLE (hl_${hl_name} ${hl_name}.c)
+ H5_NAMING (hl_${hl_name})
+ TARGET_LINK_LIBRARIES (hl_${hl_name}
+ ${HDF5_HL_LIB_TARGET}
+ ${HDF5_LIB_TARGET}
+ ${HDF5_TEST_LIB_TARGET}
+ )
+
+ ADD_TEST (NAME hl_${hl_name} COMMAND $<TARGET_FILE:hl_${hl_name}>)
+
+ #-- Copy the necessary files.
+ FOREACH (h5_file ${files})
+ SET (dest "${HDF5_HL_TEST_BINARY_DIR}/${h5_file}")
+ #MESSAGE (STATUS " Copying HL Test File ${h5_file} to ${dest}")
+ ADD_CUSTOM_COMMAND (
+ TARGET hl_${hl_name}
+ PRE_BUILD
+ COMMAND ${CMAKE_COMMAND}
+ ARGS -E copy_if_different ${HDF5_HL_TEST_SOURCE_DIR}/${h5_file} ${dest}
+ )
+
+ ENDFOREACH (h5_file ${HL_REFERENCE_TEST_FILES})
+ENDMACRO (HL_ADD_TEST)
+
+HL_ADD_TEST (test_ds "dsdata.txt;dslat.txt;dslon.txt;test_ds_be.h5;test_ds_le.h5")
+HL_ADD_TEST (test_image "image8.txt;sepia.pal;earth.pal;image24pixel.txt;image24plane.txt;usa.wri")
+HL_ADD_TEST (test_lite "dtype_file.txt")
+HL_ADD_TEST (test_packet "")
+HL_ADD_TEST (test_table "test_table_be.hdf5;test_table_cray.hdf5;test_table_le.hdf5")
+
+# --------------------------------------------------------------------
+# This executable is used to generate test files for the test_ds test.
+# It should only be run during development when new test files are needed
+# --------------------------------------------------------------------
+IF (NOT BUILD_SHARED_LIBS)
+ ADD_EXECUTABLE (hl_gen_test_ds gen_test_ds.c)
+ H5_NAMING (hl_gen_test_ds)
+ TARGET_LINK_LIBRARIES (hl_gen_test_ds
+ ${HDF5_HL_LIB_TARGET}
+ ${HDF5_LIB_TARGET}
+ ${HDF5_TEST_LIB_TARGET}
+ )
+ENDIF (NOT BUILD_SHARED_LIBS)