summaryrefslogtreecommitdiffstats
path: root/hl/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-10-06 20:49:54 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-10-06 20:49:54 (GMT)
commit1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3 (patch)
tree1498397d4ed074adb7798ebff8c6df68ddb829d8 /hl/test/CMakeLists.txt
parent1f370978b464b2c189194283a96e2794f51754eb (diff)
downloadhdf5-1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3.zip
hdf5-1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3.tar.gz
hdf5-1f2c4afe7739e6464eeaae64e7abcb5bd589f9e3.tar.bz2
[svn-r19527] Add clear generated objects commands to test blocks.
Add configurefile command to copy CTestCustom to build folder. Tested: local linux
Diffstat (limited to 'hl/test/CMakeLists.txt')
-rw-r--r--hl/test/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/hl/test/CMakeLists.txt b/hl/test/CMakeLists.txt
index 182fd14..22568ae 100644
--- a/hl/test/CMakeLists.txt
+++ b/hl/test/CMakeLists.txt
@@ -48,6 +48,33 @@ MACRO (HL_ADD_TEST hl_name files)
ENDFOREACH (h5_file ${HL_REFERENCE_TEST_FILES})
ENDMACRO (HL_ADD_TEST)
+# Remove any output file left over from previous test run
+ADD_TEST (
+ NAME hl_test-clear-objects
+ COMMAND ${CMAKE_COMMAND}
+ -E remove
+ combine_tables1.h5
+ combine_tables2.h5
+ test_detach.h5
+ test_ds1.h5
+ test_ds2.h5
+ test_ds3.h5
+ test_ds4.h5
+ test_ds5.h5
+ test_ds6.h5
+ test_ds7.h5
+ test_ds8.h5
+ test_ds9.h5
+ test_image1.h5
+ test_image2.h5
+ test_image3.h5
+ test_lite1.h5
+ test_lite2.h5
+ test_packet_compress.h5
+ test_packet_table.h5
+ test_table.h5
+)
+
HL_ADD_TEST (test_ds "dsdata.txt;dslat.txt;dslon.txt;test_ds_be.h5;test_ds_le.h5")
HL_ADD_TEST (test_image "image8.txt;sepia.pal;earth.pal;image24pixel.txt;image24plane.txt;usa.wri")
HL_ADD_TEST (test_lite "dtype_file.txt")