summaryrefslogtreecommitdiffstats
path: root/hl/test/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-01 03:19:33 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-01 03:19:33 (GMT)
commit1157fb4eb37e02d7dbd30dbf9779ac167a42d387 (patch)
tree3df41f4d8210ce0bfedd8b54e7408a41c5ea4e3a /hl/test/Makefile.am
parent26303241febadd20aea77fc8a1d48f05823170af (diff)
downloadhdf5-1157fb4eb37e02d7dbd30dbf9779ac167a42d387.zip
hdf5-1157fb4eb37e02d7dbd30dbf9779ac167a42d387.tar.gz
hdf5-1157fb4eb37e02d7dbd30dbf9779ac167a42d387.tar.bz2
[svn-r9903] Purpose:
Configuration update Description: HDF5 now uses automake Solution: Ditto to previous checkin.
Diffstat (limited to 'hl/test/Makefile.am')
-rw-r--r--hl/test/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/hl/test/Makefile.am b/hl/test/Makefile.am
new file mode 100644
index 0000000..4e55026
--- /dev/null
+++ b/hl/test/Makefile.am
@@ -0,0 +1,26 @@
+# Copyright (C) 2001 National Center for Supercomputing Applications.
+# All rights reserved.
+#
+#
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 High-Level Test Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Add include directories to C preprocessor flags
+AM_CPPFLAGS=-I. -I$(srcdir) -I$(top_builddir)/src -I$(top_srcdir)/src -I$(top_srcdir)/hl/src
+
+##LIBHDF5_HL=$(top_builddir)/hl/src/libhdf5_hl.la
+
+# The tests depend on the hdf5 and hdf5_hl libraries
+LDADD=$(LIBH5_HL) $(LIBHDF5)
+
+# Test programs. These are our main targets. They should be listed in the
+# order to be executed, generally most specific tests to least specific tests.
+TEST_PROG=test_lite test_image test_table
+check_PROGRAMS=$(TEST_PROG)
+
+include $(top_srcdir)/config/conclude.am