summaryrefslogtreecommitdiffstats
path: root/hl/test/Makefile.am
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2016-03-04 19:49:14 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2016-03-04 19:49:14 (GMT)
commit9592119ffd4b87b3cdb08f1ad8eaf7f3d221554c (patch)
tree7cf325e26c3422dadb5d2e0e73e73ab4a0cf583c /hl/test/Makefile.am
parent6e7e6bb3aa3b0106d44d7b50e79d1c6281940257 (diff)
downloadhdf5-9592119ffd4b87b3cdb08f1ad8eaf7f3d221554c.zip
hdf5-9592119ffd4b87b3cdb08f1ad8eaf7f3d221554c.tar.gz
hdf5-9592119ffd4b87b3cdb08f1ad8eaf7f3d221554c.tar.bz2
[svn-r29269] Purpose: Improve Packet Table library
Description: The Packet Table API used to have fixed-length and variable-length functions (i.e., H5PTcreate_fl and H5PTcreate_vl), but in 2006, the vlen functions were ifdef'ed out with VLPT_REMOVED, see HDFFV-442. The majority of this revision includes removing unused vlen stuff, adding various vlen tests, initial code cleanup, and first pass of commenting. Details: - Removed the VLPT_REMOVED ifdef, but keep H5PTis_varlen and the free function because they are useful or even needed, but the free function's name is changed to be more appropriate for both read/write buffers, i.e., H5PTfree_vlen_buff. - The new test file, test_packet_vlen.c, contains tests showing packet tables, containing various types of vlen data, can be created with the fixed-length function - Two accessor functions were added per HDFFV-8623/patch 003. /* Returns the ID of the dataset associated with the packet table */ hid_t H5PTget_dataset(hid_t table_id); /* Returns the ID of the datatype the packet table uses */ hid_t H5PTget_type(hid_t table_id); - Various cleanup: replacing 0/-1 with SUCCEED/FAIL and H5I_BADID with H5I_INVALID_HID, and removing many warnings. Platforms tested: Linux/32 2.6 (jam) Linux/64 (platypus) Darwin (osx1010test)
Diffstat (limited to 'hl/test/Makefile.am')
-rw-r--r--hl/test/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/hl/test/Makefile.am b/hl/test/Makefile.am
index 0809deb..32d14b6 100644
--- a/hl/test/Makefile.am
+++ b/hl/test/Makefile.am
@@ -49,4 +49,7 @@ CHECK_CLEANFILES+=combine_tables[1-2].h5 test_ds[1-9].h5 test_ds10.h5 \
test_packet_table.h5 test_packet_compress.h5 test_detach.h5 \
test_dectris.h5
+# Sources for test_packet executable
+test_packet_SOURCES=test_packet.c test_packet_vlen.c
+
include $(top_srcdir)/config/conclude.am