summaryrefslogtreecommitdiffstats
path: root/hl/test/Makefile.am
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2012-11-07 17:08:46 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2012-11-07 17:08:46 (GMT)
commitb7041a91cd7b322007e87ee3b37729ce0319a56c (patch)
tree17b06d4659ecd7add14830d8e9ca3569544aca8e /hl/test/Makefile.am
parent0cf58a4755eb6f3e7be64b0f05f2bb8ef6f7ad0d (diff)
downloadhdf5-b7041a91cd7b322007e87ee3b37729ce0319a56c.zip
hdf5-b7041a91cd7b322007e87ee3b37729ce0319a56c.tar.gz
hdf5-b7041a91cd7b322007e87ee3b37729ce0319a56c.tar.bz2
[svn-r23017] I added a prototype function H5DOwrite_chunk in HL library for Dectris people to test performance. The library's API function H5PSIdirect_write
is still in. I reorganized the internal library by adding H5D__pre_write function. Tested on koala.
Diffstat (limited to 'hl/test/Makefile.am')
-rw-r--r--hl/test/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/hl/test/Makefile.am b/hl/test/Makefile.am
index 8893b93..0809deb 100644
--- a/hl/test/Makefile.am
+++ b/hl/test/Makefile.am
@@ -29,7 +29,7 @@ LDADD=$(LIBH5_HL) $(LIBH5TEST) $(LIBHDF5)
# Test programs. These are our main targets. They should be listed in the
# order to be executed, generally most specific tests to least specific tests.
-TEST_PROG=test_lite test_image test_file_image test_table test_ds test_packet
+TEST_PROG=test_lite test_image test_file_image test_table test_ds test_packet test_dset_opt
check_PROGRAMS=$(TEST_PROG)
# These programs generate test files for the tests. They don't need to be
@@ -46,6 +46,7 @@ endif
# Temporary files. These files are the ones created by running `make test'.
CHECK_CLEANFILES+=combine_tables[1-2].h5 test_ds[1-9].h5 test_ds10.h5 \
test_image[1-3].h5 file_img[1-2].h5 test_lite[1-4].h5 test_table.h5 \
- test_packet_table.h5 test_packet_compress.h5 test_detach.h5
+ test_packet_table.h5 test_packet_compress.h5 test_detach.h5 \
+ test_dectris.h5
include $(top_srcdir)/config/conclude.am