summaryrefslogtreecommitdiffstats
path: root/hl/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-03-20 22:41:53 (GMT)
committerGitHub <noreply@github.com>2023-03-20 22:41:53 (GMT)
commitf1e7081cc28b3af0077af71605df7320aa1b9312 (patch)
tree1873fb4c23c1d55462db723d30736cf65f2eb108 /hl/tools/CMakeLists.txt
parent69f3562e312356fe5c58bcc94f0faecdf4af32cf (diff)
downloadhdf5-f1e7081cc28b3af0077af71605df7320aa1b9312.zip
hdf5-f1e7081cc28b3af0077af71605df7320aa1b9312.tar.gz
hdf5-f1e7081cc28b3af0077af71605df7320aa1b9312.tar.bz2
Add Option to not build gif tools and remove javadoc option (#2611)
* Add Option to not build gif tools and remove javadoc option * Remove old option * Fix CMake command format
Diffstat (limited to 'hl/tools/CMakeLists.txt')
-rw-r--r--hl/tools/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/hl/tools/CMakeLists.txt b/hl/tools/CMakeLists.txt
index fd9b6d9..a0bd744 100644
--- a/hl/tools/CMakeLists.txt
+++ b/hl/tools/CMakeLists.txt
@@ -1,6 +1,12 @@
cmake_minimum_required (VERSION 3.12)
project (HDF5_HL_TOOLS C)
-add_subdirectory (gif2h5)
+#-----------------------------------------------------------------------------
+#-- Option to build the High level GIF Tools
+#-----------------------------------------------------------------------------
+option (HDF5_BUILD_HL_GIF_TOOLS "Build HDF5 HL GIF Tools" OFF)
+if (HDF5_BUILD_HL_GIF_TOOLS)
+ add_subdirectory (gif2h5)
+endif ()
add_subdirectory (h5watch)