summaryrefslogtreecommitdiffstats
path: root/hl/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-12-24 00:05:31 (GMT)
committerGitHub <noreply@github.com>2022-12-24 00:05:31 (GMT)
commitcfd5059e77e2e411a94a13d2fb033224736be09d (patch)
treec81153efc8899be0ba197d0ae1355d55351cbd03 /hl/tools/CMakeLists.txt
parent9a694db450d3d62d63910887bd8485ae76124807 (diff)
downloadhdf5-cfd5059e77e2e411a94a13d2fb033224736be09d.zip
hdf5-cfd5059e77e2e411a94a13d2fb033224736be09d.tar.gz
hdf5-cfd5059e77e2e411a94a13d2fb033224736be09d.tar.bz2
HL GIF tools changes (#2360)
* Fixes the broken Autotools option * Removes the "build HL tools" option
Diffstat (limited to 'hl/tools/CMakeLists.txt')
-rw-r--r--hl/tools/CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/hl/tools/CMakeLists.txt b/hl/tools/CMakeLists.txt
index 7df2b79..a369d9e 100644
--- a/hl/tools/CMakeLists.txt
+++ b/hl/tools/CMakeLists.txt
@@ -1,14 +1,12 @@
cmake_minimum_required (VERSION 3.18)
project (HDF5_HL_TOOLS C)
- #-----------------------------------------------------------------------------
- #-- Option to build the High level GIF Tools
- #-----------------------------------------------------------------------------
- if (EXISTS "${HDF5_HL_SOURCE_DIR}/gif2h5" AND IS_DIRECTORY "${HDF5_HL_SOURCE_DIR}/gif2h5")
- option (HDF5_BUILD_HL_GIF_TOOLS "Build HDF5 HL GIF Tools" OFF)
- if (HDF5_BUILD_HL_GIF_TOOLS)
- add_subdirectory (gif2h5)
- endif ()
- endif ()
+#-----------------------------------------------------------------------------
+#-- Option to build the High level GIF Tools
+#-----------------------------------------------------------------------------
+option (HDF5_BUILD_HL_GIF_TOOLS "Build HDF5 HL GIF Tools" OFF)
+if (HDF5_BUILD_HL_GIF_TOOLS)
+ add_subdirectory (gif2h5)
+endif ()
add_subdirectory (h5watch)