summaryrefslogtreecommitdiffstats
path: root/hl/tools/gif2h5/Makefile.am
diff options
context:
space:
mode:
authorPedro Vicente Nunes <pvn@hdfgroup.org>2006-02-10 16:29:34 (GMT)
committerPedro Vicente Nunes <pvn@hdfgroup.org>2006-02-10 16:29:34 (GMT)
commited9449e0092f4e6ffa2279f07017e7cc4061fece (patch)
treecce7f26804d9eeefd98646b0f6180641d0593210 /hl/tools/gif2h5/Makefile.am
parentf6dd21fb11c6a5fa8503b0614715cdfdf738d380 (diff)
downloadhdf5-ed9449e0092f4e6ffa2279f07017e7cc4061fece.zip
hdf5-ed9449e0092f4e6ffa2279f07017e7cc4061fece.tar.gz
hdf5-ed9449e0092f4e6ffa2279f07017e7cc4061fece.tar.bz2
[svn-r11932] Purpose:
bug fix Description: the --disable-hl switch was causing linking errors on gif2h5 that uses image api (bugzilla #1) Solution: used the condional macro for hl to build gif2h5 Platforms tested: linux Misc. update:
Diffstat (limited to 'hl/tools/gif2h5/Makefile.am')
-rw-r--r--hl/tools/gif2h5/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/hl/tools/gif2h5/Makefile.am b/hl/tools/gif2h5/Makefile.am
index 5318869..e8f6a56 100644
--- a/hl/tools/gif2h5/Makefile.am
+++ b/hl/tools/gif2h5/Makefile.am
@@ -23,12 +23,28 @@ include $(top_srcdir)/config/commence.am
INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib -I$(top_srcdir)/hl/src
# These are our main targets, the tools
+
+if BUILD_HDF5_HL_CONDITIONAL
bin_PROGRAMS=gif2h5 h52gif
+else
+bin_PROGRAMS=h52gif
+endif
+if BUILD_HDF5_HL_CONDITIONAL
gif2h5_SOURCES=gif2hdf.c gif2mem.c decompress.c gifread.c writehdf.c
+endif
+
h52gif_SOURCES=hdf2gif.c hdfgifwr.c readhdf.c
+
+
# Programs all depend on the hdf5 library and the tools library
+if BUILD_HDF5_HL_CONDITIONAL
LDADD=$(LIBH5TOOLS) $(LIBH5_HL) $(LIBHDF5)
+else
+LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+endif
+
+
include $(top_srcdir)/config/conclude.am