summaryrefslogtreecommitdiffstats
path: root/hl/tools/gif2h5/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-03-03 21:49:10 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-03-03 21:49:10 (GMT)
commitea9f792cd794024f766fc844b49f9eda73e9bc14 (patch)
treea6f32669a2272b7f87e5af94aceebef50639f9e5 /hl/tools/gif2h5/Makefile.am
parent142705d983f9ac719ad7e64fa66b4f0aa25fad70 (diff)
downloadhdf5-ea9f792cd794024f766fc844b49f9eda73e9bc14.zip
hdf5-ea9f792cd794024f766fc844b49f9eda73e9bc14.tar.gz
hdf5-ea9f792cd794024f766fc844b49f9eda73e9bc14.tar.bz2
[svn-r12001] Purpose:
Moved gif2h5 tool to hl directory Description: Added a tools directory under the hl directory and moved the gif2h5 tool to that directory. Solution: The gif2h5 tool was originally built in the tools directory, but this introduced dependency issues that required special checks in the Makefiles.am and required the top-level build order to be changed because it depended on the HL library. For simplicity in the Makefiles now and in the future, the gif2h5 tool was moved to be underneath the hl library. Platforms tested: mir, copper, modi4, shanti
Diffstat (limited to 'hl/tools/gif2h5/Makefile.am')
-rw-r--r--hl/tools/gif2h5/Makefile.am19
1 files changed, 3 insertions, 16 deletions
diff --git a/hl/tools/gif2h5/Makefile.am b/hl/tools/gif2h5/Makefile.am
index e8f6a56..cd5c305 100644
--- a/hl/tools/gif2h5/Makefile.am
+++ b/hl/tools/gif2h5/Makefile.am
@@ -24,27 +24,14 @@ INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib -I$(top_srcdir)/hl/src
# These are our main targets, the tools
-if BUILD_HDF5_HL_CONDITIONAL
bin_PROGRAMS=gif2h5 h52gif
-else
-bin_PROGRAMS=h52gif
-endif
-if BUILD_HDF5_HL_CONDITIONAL
gif2h5_SOURCES=gif2hdf.c gif2mem.c decompress.c gifread.c writehdf.c
-endif
h52gif_SOURCES=hdf2gif.c hdfgifwr.c readhdf.c
-
-
-# Programs all depend on the hdf5 library and the tools library
-if BUILD_HDF5_HL_CONDITIONAL
-LDADD=$(LIBH5TOOLS) $(LIBH5_HL) $(LIBHDF5)
-else
-LDADD=$(LIBH5TOOLS) $(LIBHDF5)
-endif
-
-
+# Programs all depend on the hdf5 library, the tools library, and the HL
+# library.
+LDADD=$(LIBH5_HL) $(LIBH5TOOLS) $(LIBHDF5)
include $(top_srcdir)/config/conclude.am