summaryrefslogtreecommitdiffstats
path: root/hl/tools/h5watch/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-01-15 17:38:06 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-05-20 14:20:26 (GMT)
commit6682c717e263ed3f3465766f9664f3b7ff115841 (patch)
tree3be4f156651c4fef09a0f66779fd72f577618c7b /hl/tools/h5watch/CMakeLists.txt
parent9ebf36e8937995ae88243164a914e0743a8bbbd6 (diff)
downloadhdf5-6682c717e263ed3f3465766f9664f3b7ff115841.zip
hdf5-6682c717e263ed3f3465766f9664f3b7ff115841.tar.gz
hdf5-6682c717e263ed3f3465766f9664f3b7ff115841.tar.bz2
HDFFV-11001 Add fine control over testing
Diffstat (limited to 'hl/tools/h5watch/CMakeLists.txt')
-rw-r--r--hl/tools/h5watch/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/hl/tools/h5watch/CMakeLists.txt b/hl/tools/h5watch/CMakeLists.txt
index b3d65f7..0ea0af4 100644
--- a/hl/tools/h5watch/CMakeLists.txt
+++ b/hl/tools/h5watch/CMakeLists.txt
@@ -26,7 +26,7 @@ if (BUILD_SHARED_LIBS)
set (H5_DEP_EXECUTABLES ${H5_DEP_EXECUTABLES} h5watch-shared)
endif ()
-if (BUILD_TESTING)
+if (BUILD_TESTING AND HDF5_TEST_SWMR)
#-- Add swmr_check_compat_vfd program
set (hl_swmr_check_compat_vfd_SOURCES
${HDF5_HL_TOOLS_H5WATCH_SOURCE_DIR}/swmr_check_compat_vfd.c
@@ -68,7 +68,9 @@ if (BUILD_TESTING)
endif ()
set_target_properties (h5watchgentest PROPERTIES FOLDER generator/tools/hl)
- include (CMakeTests.cmake)
+ if (HDF5_TEST_TOOLS)
+ include (CMakeTests.cmake)
+ endif ()
endif ()
#-----------------------------------------------------------------------------