summaryrefslogtreecommitdiffstats
path: root/hl/tools/h5watch/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2016-12-28 21:03:17 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2016-12-28 21:03:17 (GMT)
commit27feb0357f455ff19e382b0a51cd1c3926d1156f (patch)
tree5383ab2f552cc4dc9424d8f8e403108a809a35c8 /hl/tools/h5watch/CMakeLists.txt
parentb00962ac8694b14b74382f77d1cf849b93383fb5 (diff)
downloadhdf5-27feb0357f455ff19e382b0a51cd1c3926d1156f.zip
hdf5-27feb0357f455ff19e382b0a51cd1c3926d1156f.tar.gz
hdf5-27feb0357f455ff19e382b0a51cd1c3926d1156f.tar.bz2
Fix h5test.h include issue
Diffstat (limited to 'hl/tools/h5watch/CMakeLists.txt')
-rw-r--r--hl/tools/h5watch/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/hl/tools/h5watch/CMakeLists.txt b/hl/tools/h5watch/CMakeLists.txt
index e3a7e9d..c982c8f 100644
--- a/hl/tools/h5watch/CMakeLists.txt
+++ b/hl/tools/h5watch/CMakeLists.txt
@@ -9,9 +9,9 @@ set (H5WATCH_SOURCES
)
#-- Add h5watch program
-INCLUDE_DIRECTORIES (${HDF5_TOOLS_DIR}/lib)
-INCLUDE_DIRECTORIES (${HDF5_HL_TOOLS_DIR}/src)
-INCLUDE_DIRECTORIES (${HDF5_HL_TOOLS_H5WATCH_SOURCE_DIR})
+include_directories (${HDF5_TOOLS_DIR}/lib)
+include_directories (${HDF5_HL_TOOLS_DIR}/src)
+include_directories (${HDF5_HL_TOOLS_H5WATCH_SOURCE_DIR})
add_executable (h5watch ${H5WATCH_SOURCES})
TARGET_NAMING (h5watch STATIC)
@@ -20,6 +20,8 @@ target_link_libraries (h5watch ${HDF5_HL_LIB_TARGET} ${HDF5_LIB_TARGET} ${HDF5_T
set_target_properties (h5watch PROPERTIES FOLDER tools/hl)
if (BUILD_TESTING)
+ include_directories (${HDF5_TEST_SRC_DIR})
+ include_directories(${HDF5_HL_SRC_DIR}/test)
#-- Add swmr_check_compat_vfd program
set (hl_swmr_check_compat_vfd_SOURCES
${HDF5_HL_TOOLS_H5WATCH_SOURCE_DIR}/swmr_check_compat_vfd.c