summaryrefslogtreecommitdiffstats
path: root/hl/tools/h5watch/Makefile.am
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2016-12-20 04:44:54 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2016-12-20 04:44:54 (GMT)
commiteefddf281366e8327dd7397db4a2f2e7edabcf17 (patch)
tree913e8a1ed10612b40fd6b8c6976e2dbdfc647467 /hl/tools/h5watch/Makefile.am
parentab3963b28e59419f8e857ec224dd4efa3ea6dd8e (diff)
downloadhdf5-eefddf281366e8327dd7397db4a2f2e7edabcf17.zip
hdf5-eefddf281366e8327dd7397db4a2f2e7edabcf17.tar.gz
hdf5-eefddf281366e8327dd7397db4a2f2e7edabcf17.tar.bz2
Bring new/updated tests from revise+chunks branch: flush1/flush2 update and
flushrefresh test. (Also refactor of message send / wait code)
Diffstat (limited to 'hl/tools/h5watch/Makefile.am')
-rw-r--r--hl/tools/h5watch/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/hl/tools/h5watch/Makefile.am b/hl/tools/h5watch/Makefile.am
index a5891ef..35a08e6 100644
--- a/hl/tools/h5watch/Makefile.am
+++ b/hl/tools/h5watch/Makefile.am
@@ -37,6 +37,14 @@ h5watch_LDFLAGS = $(LT_STATIC_EXEC) $(AM_LDFLAGS)
# Programs all depend on the hdf5 library, the tools library, and the HL
# library.
LDADD=$(LIBH5_HL) $(LIBH5TOOLS) $(LIBHDF5)
+
+# Add extend_dset specific preprocessor flags here
+# (add the main test subdirectory to the include file path)
+extend_dset_CPPFLAGS=$(AM_CPPFLAGS) -I$(top_srcdir)/test
+# Add extend_dset specific library flags here
+# (add the main test library to the list of libraries)
+extend_dset_LDADD=$(LDADD) $(LIBH5TEST)
+
#
CHECK_CLEANFILES+=*.h5
DISTCLEANFILES=testh5watch.sh