summaryrefslogtreecommitdiffstats
path: root/java/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-01-30 18:21:01 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-01-30 18:21:01 (GMT)
commit2f18da435e537118e1405f7f9fef3f3e29a346f2 (patch)
treef21b3f34c568e31e0198d09653a6a750614960d2 /java/CMakeLists.txt
parentbd7bc909ed2c950e75772c3876f9a236799565c5 (diff)
downloadhdf5-2f18da435e537118e1405f7f9fef3f3e29a346f2.zip
hdf5-2f18da435e537118e1405f7f9fef3f3e29a346f2.tar.gz
hdf5-2f18da435e537118e1405f7f9fef3f3e29a346f2.tar.bz2
HDFFV-10398 use the simpler add_subdirectory signature
Diffstat (limited to 'java/CMakeLists.txt')
-rw-r--r--java/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/java/CMakeLists.txt b/java/CMakeLists.txt
index 68860be..9a5692f 100644
--- a/java/CMakeLists.txt
+++ b/java/CMakeLists.txt
@@ -36,20 +36,20 @@ set (CMAKE_JAVA_INCLUDE_PATH "")
#-----------------------------------------------------------------------------
# Traverse source subdirectory
#-----------------------------------------------------------------------------
-add_subdirectory (${HDF5_JAVA_SOURCE_DIR}/src ${HDF5_JAVA_BINARY_DIR}/src)
+add_subdirectory (src)
#-----------------------------------------------------------------------------
# Build the Java Examples
#-----------------------------------------------------------------------------
if (HDF5_BUILD_EXAMPLES)
- add_subdirectory (${HDF5_JAVA_SOURCE_DIR}/examples ${HDF5_JAVA_BINARY_DIR}/examples)
+ add_subdirectory (examples)
endif ()
#-----------------------------------------------------------------------------
# Testing
#-----------------------------------------------------------------------------
if (BUILD_TESTING)
- add_subdirectory (${HDF5_JAVA_SOURCE_DIR}/test ${HDF5_JAVA_BINARY_DIR}/test)
+ add_subdirectory (test)
endif ()
#-----------------------------------------------------------------------------