summaryrefslogtreecommitdiffstats
path: root/java/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2019-06-06 04:20:01 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2019-06-06 04:20:01 (GMT)
commit54a07f556cd2f3556f8c7946fe7905bc658a11aa (patch)
tree2563b439aa79df337a7d4b4ec884be0d535ee1b8 /java/Makefile.am
parent4af633d1c480deb7d27c1da7ee2c512a2500e543 (diff)
downloadhdf5-54a07f556cd2f3556f8c7946fe7905bc658a11aa.zip
hdf5-54a07f556cd2f3556f8c7946fe7905bc658a11aa.tar.gz
hdf5-54a07f556cd2f3556f8c7946fe7905bc658a11aa.tar.bz2
Add options to enable or disable building tools and tests. The default
is enabled for each.
Diffstat (limited to 'java/Makefile.am')
-rw-r--r--java/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/java/Makefile.am b/java/Makefile.am
index ed2414d..51398f2 100644
--- a/java/Makefile.am
+++ b/java/Makefile.am
@@ -23,13 +23,21 @@
include $(top_srcdir)/config/commence.am
+if BUILD_TESTS_CONDITIONAL
+ TESTSERIAL_DIR =test
+ TESTEXAMPLES_DIR =examples
+else
+ TESTSERIAL_DIR=
+ TESTEXAMPLES_DIR=
+endif
+
## Only recurse into subdirectories if the Java (JNI) interface is enabled.
if BUILD_JAVA_CONDITIONAL
# Mark this directory as part of the JNI API
JAVA_API=yes
-SUBDIRS=src test examples
+SUBDIRS=src $(TESTSERIAL_DIR) $(TESTEXAMPLES_DIR)
# Test with just the native connector, with a single pass-through connector
# and with a doubly-stacked pass-through.