summaryrefslogtreecommitdiffstats
path: root/java/examples/datasets/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-10-02 17:39:15 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-10-02 17:39:15 (GMT)
commit4f9e47650aa98d1048da87be44ff3d28685554b7 (patch)
tree80bd1e918a76f086e8aef5cb3d5034f2d94d41cc /java/examples/datasets/CMakeLists.txt
parent19ee2f9dc8ce4352b3ec82c667abecb47a1d9684 (diff)
downloadhdf5-4f9e47650aa98d1048da87be44ff3d28685554b7.zip
hdf5-4f9e47650aa98d1048da87be44ff3d28685554b7.tar.gz
hdf5-4f9e47650aa98d1048da87be44ff3d28685554b7.tar.bz2
Fix STREQUAL if commands.
Diffstat (limited to 'java/examples/datasets/CMakeLists.txt')
-rw-r--r--java/examples/datasets/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/java/examples/datasets/CMakeLists.txt b/java/examples/datasets/CMakeLists.txt
index d698cfd..3972ec8 100644
--- a/java/examples/datasets/CMakeLists.txt
+++ b/java/examples/datasets/CMakeLists.txt
@@ -101,7 +101,7 @@ if (BUILD_TESTING)
endif (H5_HAVE_FILTER_SZIP)
foreach (example ${HDF_JAVA_EXAMPLES})
- if (${example} STREQUAL "H5Ex_D_External")
+ if ("${example}" STREQUAL "H5Ex_D_External")
add_test (
NAME JAVA_datasets-${example}-clear-objects
COMMAND ${CMAKE_COMMAND}
@@ -129,7 +129,7 @@ if (BUILD_TESTING)
)
set_tests_properties (JAVA_datasets-${example}-copy-objects PROPERTIES DEPENDS JAVA_datasets-${example}-clear-objects)
set (last_test "JAVA_datasets-${example}-copy-objects")
- if (${example} STREQUAL "H5Ex_D_Szip")
+ if ("${example}" STREQUAL "H5Ex_D_Szip")
if (USE_FILTER_SZIP)
ADD_H5_TEST (${example} 0)
endif ()