summaryrefslogtreecommitdiffstats
path: root/java/examples/intro/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2016-03-22 14:40:32 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2016-03-22 14:40:32 (GMT)
commitaf4739e677f6edd5572b9250827039914221c185 (patch)
treedf3af4b4860eef2333bbde2f25164cfd80df2f08 /java/examples/intro/Makefile.am
parentc051bc75745b141736d5d27fed44de1ad24f5f37 (diff)
downloadhdf5-af4739e677f6edd5572b9250827039914221c185.zip
hdf5-af4739e677f6edd5572b9250827039914221c185.tar.gz
hdf5-af4739e677f6edd5572b9250827039914221c185.tar.bz2
[svn-r29506] Merge of r29465 from trunk.
Java build tweaks Tested on: jam
Diffstat (limited to 'java/examples/intro/Makefile.am')
-rw-r--r--java/examples/intro/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/java/examples/intro/Makefile.am b/java/examples/intro/Makefile.am
index fef33d2..3d5757a 100644
--- a/java/examples/intro/Makefile.am
+++ b/java/examples/intro/Makefile.am
@@ -26,7 +26,7 @@ JAVA_API=yes
JAVAROOT = .classes
classes:
- $(MKDIR_P) $(@D)/$(JAVAROOT)
+ test -d $(@D)/$(JAVAROOT) || $(MKDIR_P) $(@D)/$(JAVAROOT)
pkgpath = examples/intro
hdfjarfile = jar$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).jar
@@ -60,7 +60,7 @@ TEST_SCRIPT = $(check_SCRIPTS)
CLEANFILES = classnoinst.stamp $(jarfile) $(JAVAROOT)/$(pkgpath)/*.class runExample.sh
clean:
- rm -rf $(JAVAROOT)
+ rm -rf $(JAVAROOT)/*
rm -f $(jarfile)
rm -f classnoinst.stamp