summaryrefslogtreecommitdiffstats
path: root/java/src/jni/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-03-30 18:10:36 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-03-30 18:10:36 (GMT)
commit944cbb940009119de7ccae8a42734b38d03ea2c7 (patch)
treeb9d49b1c9264e988c533a53c3052abf4d292faf5 /java/src/jni/CMakeLists.txt
parent4c14a0e3db852b6f1e9811a7396d85cc81c85ea8 (diff)
downloadhdf5-944cbb940009119de7ccae8a42734b38d03ea2c7.zip
hdf5-944cbb940009119de7ccae8a42734b38d03ea2c7.tar.gz
hdf5-944cbb940009119de7ccae8a42734b38d03ea2c7.tar.bz2
TRILAB-192 merging warnings changes from develop
Diffstat (limited to 'java/src/jni/CMakeLists.txt')
-rw-r--r--java/src/jni/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/java/src/jni/CMakeLists.txt b/java/src/jni/CMakeLists.txt
index 386a908..9440eef 100644
--- a/java/src/jni/CMakeLists.txt
+++ b/java/src/jni/CMakeLists.txt
@@ -77,6 +77,9 @@ add_library (${HDF5_JAVA_JNI_LIB_TARGET} SHARED ${HDF5_JAVA_JNI_CSRCS} ${HDF5_JA
target_include_directories (${HDF5_JAVA_JNI_LIB_TARGET}
PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};${HDF5_JAVA_JNI_SOURCE_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>"
)
+target_compile_options(${HDF5_JAVA_JNI_LIB_TARGET}
+ PRIVATE "${HDF5_CMAKE_C_FLAGS}"
+)
TARGET_C_PROPERTIES (${HDF5_JAVA_JNI_LIB_TARGET} SHARED)
target_link_libraries (${HDF5_JAVA_JNI_LIB_TARGET} PUBLIC ${HDF5_LIBSH_TARGET})
set_target_properties (${HDF5_JAVA_JNI_LIB_TARGET} PROPERTIES FOLDER libraries/jni)