summaryrefslogtreecommitdiffstats
path: root/java/src/jni/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-12-21 19:48:39 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-12-21 19:48:49 (GMT)
commit1efe978ae0ea97272d1796e43b1cb1b0f4e58272 (patch)
treefe7bca90f4164b8793178729a507229f87a1aed5 /java/src/jni/CMakeLists.txt
parent7cddfb09dbfb472e704e2f64ce81bb6675fb72f2 (diff)
downloadhdf5-1efe978ae0ea97272d1796e43b1cb1b0f4e58272.zip
hdf5-1efe978ae0ea97272d1796e43b1cb1b0f4e58272.tar.gz
hdf5-1efe978ae0ea97272d1796e43b1cb1b0f4e58272.tar.bz2
Fix library interface commands, add missing JNI
Diffstat (limited to 'java/src/jni/CMakeLists.txt')
-rw-r--r--java/src/jni/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/java/src/jni/CMakeLists.txt b/java/src/jni/CMakeLists.txt
index 9e6c099..10d1b6d 100644
--- a/java/src/jni/CMakeLists.txt
+++ b/java/src/jni/CMakeLists.txt
@@ -51,7 +51,7 @@ set (CMAKE_INCLUDE_CURRENT_DIR_IN_INTERFACE ON)
########### JNI libraries always must be built shared ###############
add_library (${HDF5_JAVA_JNI_LIB_TARGET} SHARED ${HDF5_JAVA_JNI_CSRCS} ${HDF5_JAVA_JNI_CHDRS})
TARGET_C_PROPERTIES (${HDF5_JAVA_JNI_LIB_TARGET} SHARED " " " ")
-target_link_libraries (${HDF5_JAVA_JNI_LIB_TARGET} ${HDF5_LIB_TARGET})
+target_link_libraries (${HDF5_JAVA_JNI_LIB_TARGET} PUBLIC ${HDF5_LIB_TARGET})
set_target_properties (${HDF5_JAVA_JNI_LIB_TARGET} PROPERTIES FOLDER libraries/jni)
SET_GLOBAL_VARIABLE (HDF5_LIBRARIES_TO_EXPORT "${HDF5_LIBRARIES_TO_EXPORT};${HDF5_JAVA_JNI_LIB_TARGET}")
H5_SET_LIB_OPTIONS (${HDF5_JAVA_JNI_LIB_TARGET} ${HDF5_JAVA_JNI_LIB_NAME} SHARED ${HDF5_JAVA_PACKAGE_SOVERSION})