summaryrefslogtreecommitdiffstats
path: root/java/src/jni/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-01-17 16:27:00 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-01-17 16:27:00 (GMT)
commit6ca95c512a116340b6e483882a4a3737d9d1c67c (patch)
tree931c0f4023e164f68cfdbd8ad6215a9837c1ae01 /java/src/jni/CMakeLists.txt
parent0291c0907502b8d1b2f0328a97c2f19ca16c7370 (diff)
downloadhdf5-6ca95c512a116340b6e483882a4a3737d9d1c67c.zip
hdf5-6ca95c512a116340b6e483882a4a3737d9d1c67c.tar.gz
hdf5-6ca95c512a116340b6e483882a4a3737d9d1c67c.tar.bz2
HDFFV-10385 rework java names
Diffstat (limited to 'java/src/jni/CMakeLists.txt')
-rw-r--r--java/src/jni/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/java/src/jni/CMakeLists.txt b/java/src/jni/CMakeLists.txt
index 10d1b6d..ea9665b 100644
--- a/java/src/jni/CMakeLists.txt
+++ b/java/src/jni/CMakeLists.txt
@@ -57,9 +57,7 @@ SET_GLOBAL_VARIABLE (HDF5_LIBRARIES_TO_EXPORT "${HDF5_LIBRARIES_TO_EXPORT};${HDF
H5_SET_LIB_OPTIONS (${HDF5_JAVA_JNI_LIB_TARGET} ${HDF5_JAVA_JNI_LIB_NAME} SHARED ${HDF5_JAVA_PACKAGE_SOVERSION})
if (WIN32)
get_filename_component (HDF5_JAVA_JNI_DLL_NAME ${HDF5_JAVA_JNI_LIB_TARGET} NAME_WE)
- if (CMAKE_BUILD_TYPE MATCHES Debug)
- set (HDF5_JAVA_JNI_DLL_NAME "${HDF5_JAVA_JNI_DLL_NAME}_D")
- endif ()
+ set (HDF5_JAVA_JNI_DLL_NAME "${HDF5_JAVA_JNI_DLL_NAME}$<$<CONFIG:Debug>:_D>")
# message (STATUS "HDF5_JAVA_JNI_DLL_NAME: ${HDF5_JAVA_JNI_DLL_NAME}")
if (BUILD_TESTING)
add_custom_target (HDF5_JAVA_JNI-Test-Copy ALL