summaryrefslogtreecommitdiffstats
path: root/java/src/jni/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-04-18 16:44:47 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-04-18 16:44:47 (GMT)
commit5bbaae4495eb6f2eea309e886bccbc6051b6f534 (patch)
treeada29d682208e7f112798733b249e701b43e11ce /java/src/jni/Makefile.am
parent0b226bd28beb02165f18a9e3fdc985028ce37946 (diff)
downloadhdf5-5bbaae4495eb6f2eea309e886bccbc6051b6f534.zip
hdf5-5bbaae4495eb6f2eea309e886bccbc6051b6f534.tar.gz
hdf5-5bbaae4495eb6f2eea309e886bccbc6051b6f534.tar.bz2
java jni lib also needs to avoid the version-info
Diffstat (limited to 'java/src/jni/Makefile.am')
-rw-r--r--java/src/jni/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/java/src/jni/Makefile.am b/java/src/jni/Makefile.am
index cf627ef..5672864 100644
--- a/java/src/jni/Makefile.am
+++ b/java/src/jni/Makefile.am
@@ -31,7 +31,7 @@ AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/java/src/jni $(JNIFLAGS)
lib_LTLIBRARIES=libhdf5_java.la
# Add libtool numbers to the HDF5 Java (JNI) library (from config/lt_vers.am)
-libhdf5_java_la_LDFLAGS = -module -shared -export-dynamic -version-info $(LT_JAVA_VERS_INTERFACE):$(LT_JAVA_VERS_REVISION):$(LT_JAVA_VERS_AGE) $(AM_LDFLAGS)
+libhdf5_java_la_LDFLAGS = -avoid-version -module -shared -export-dynamic -version-info $(LT_JAVA_VERS_INTERFACE):$(LT_JAVA_VERS_REVISION):$(LT_JAVA_VERS_AGE) $(AM_LDFLAGS)
# Source files for the library
libhdf5_java_la_SOURCES=exceptionImp.c h5Constants.c nativeData.c h5util.c h5Imp.c \