summaryrefslogtreecommitdiffstats
path: root/java/src/jni/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2016-03-06 17:49:30 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2016-03-06 17:49:30 (GMT)
commit0a57cb562c116683529013c158f6873ebd5b9c34 (patch)
tree9da832cf2a41c7322dd259ffe717515e6ff0d663 /java/src/jni/Makefile.am
parentc95332e8aeacc5551d3c9541256afd98d89b01d7 (diff)
downloadhdf5-0a57cb562c116683529013c158f6873ebd5b9c34.zip
hdf5-0a57cb562c116683529013c158f6873ebd5b9c34.tar.gz
hdf5-0a57cb562c116683529013c158f6873ebd5b9c34.tar.bz2
[svn-r29291] Merge of r29226-29259 from trunk.
Mostly java JNI + a few smaller merges. Tested on: h5committest.new jam w/ java
Diffstat (limited to 'java/src/jni/Makefile.am')
-rw-r--r--java/src/jni/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/java/src/jni/Makefile.am b/java/src/jni/Makefile.am
new file mode 100644
index 0000000..764fcdb
--- /dev/null
+++ b/java/src/jni/Makefile.am
@@ -0,0 +1,44 @@
+#
+# Copyright by The HDF Group.
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdfgroup.org/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from help@hdfgroup.org.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 Java native interface (JNI) Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+include $(top_srcdir)/config/lt_vers.am
+
+# Mark this directory as part of the JNI API
+JAVA_API=yes
+
+# Include src directory and JNI flags
+AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/java/src/jni $(JNIFLAGS)
+
+# This is our main target
+lib_LTLIBRARIES=libhdf5_java.la
+
+# Add libtool numbers to the HDF5 Java (JNI) library (from config/lt_vers.am)
+libhdf5_java_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE) $(AM_LDFLAGS)
+
+# Source files for the library
+libhdf5_java_la_SOURCES=exceptionImp.c h5Constants.c nativeData.c h5util.c h5Imp.c \
+ h5aImp.c h5dImp.c h5eImp.c h5fImp.c h5gImp.c h5iImp.c h5lImp.c h5oImp.c \
+ h5pImp.c h5plImp.c h5rImp.c h5sImp.c h5tImp.c h5zImp.c
+
+# HDF5 Java (JNI) library depends on HDF5 Library.
+libhdf5_java_la_LIBADD=$(LIBHDF5)
+
+include $(top_srcdir)/config/conclude.am