summaryrefslogtreecommitdiffstats
path: root/java/src/jni/Makefile.am
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@lbl.gov>2021-07-01 23:52:04 (GMT)
committerQuincey Koziol <koziol@lbl.gov>2021-07-01 23:52:04 (GMT)
commit682fc6ba3af245cc44de9ca5e9b35527460c512a (patch)
tree1f44496a052568150f338404b34db1fdd8964a3f /java/src/jni/Makefile.am
parent8c4af2a23ef3e512507e1fdef7624f7a1fb2ab25 (diff)
downloadhdf5-682fc6ba3af245cc44de9ca5e9b35527460c512a.zip
hdf5-682fc6ba3af245cc44de9ca5e9b35527460c512a.tar.gz
hdf5-682fc6ba3af245cc44de9ca5e9b35527460c512a.tar.bz2
Jordan's patch to add test library to java builds
Diffstat (limited to 'java/src/jni/Makefile.am')
-rw-r--r--java/src/jni/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/java/src/jni/Makefile.am b/java/src/jni/Makefile.am
index bf086d2..d17d3d1 100644
--- a/java/src/jni/Makefile.am
+++ b/java/src/jni/Makefile.am
@@ -25,12 +25,15 @@ JAVA_API=yes
AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/java/src/jni $(JNIFLAGS)
# This is our main target
-lib_LTLIBRARIES=libhdf5_java.la
+lib_LTLIBRARIES=libhdf5_java.la libhdf5_java_test.la
# Add libtool numbers to the HDF5 Java (JNI) library (from config/lt_vers.am)
libhdf5_java_la_LDFLAGS = -avoid-version -shared -export-dynamic -version-info $(LT_JAVA_VERS_INTERFACE):$(LT_JAVA_VERS_REVISION):$(LT_JAVA_VERS_AGE) $(AM_LDFLAGS)
-# Source files for the library
+# Add libtool numbers to the HDF5 Java (JNI) library (from config/lt_vers.am)
+libhdf5_java_test_la_LDFLAGS = -avoid-version -shared -export-dynamic -version-info $(LT_JAVA_VERS_INTERFACE):$(LT_JAVA_VERS_REVISION):$(LT_JAVA_VERS_AGE) $(AM_LDFLAGS)
+
+# Source files for the main Java library
libhdf5_java_la_SOURCES=exceptionImp.c h5Constants.c nativeData.c h5util.c h5Imp.c \
h5aImp.c h5dImp.c h5eImp.c h5fImp.c h5gImp.c h5iImp.c h5lImp.c h5oImp.c \
h5pImp.c h5pACPLImp.c h5pDAPLImp.c h5pDCPLImp.c h5pDXPLImp.c \
@@ -38,7 +41,13 @@ libhdf5_java_la_SOURCES=exceptionImp.c h5Constants.c nativeData.c h5util.c h5Imp
h5pOCPLImp.c h5pOCpyPLImp.c h5pStrCPLImp.c h5plImp.c h5rImp.c h5sImp.c h5tImp.c \
h5vlImp.c h5zImp.c
+# Source files for the Java testing library
+libhdf5_java_test_la_SOURCES=h5jni_test.c
+
# HDF5 Java (JNI) library depends on HDF5 Library.
libhdf5_java_la_LIBADD=$(LIBHDF5)
+# HDF5 Java (JNI) Testing library depends on HDF5 Library and Java Library.
+libhdf5_java_test_la_LIBADD=$(LIBHDF5) libhdf5_java.la
+
include $(top_srcdir)/config/conclude.am