summaryrefslogtreecommitdiffstats
path: root/java/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-01-16 22:08:52 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-01-16 22:08:52 (GMT)
commit0291c0907502b8d1b2f0328a97c2f19ca16c7370 (patch)
tree3c01183846fcd64b54398ab980a927f9be66d589 /java/test/CMakeLists.txt
parent19c18e44ed113af84896604d7cedcc892f8338dc (diff)
downloadhdf5-0291c0907502b8d1b2f0328a97c2f19ca16c7370.zip
hdf5-0291c0907502b8d1b2f0328a97c2f19ca16c7370.tar.gz
hdf5-0291c0907502b8d1b2f0328a97c2f19ca16c7370.tar.bz2
HDFFV-10385 Use OUTPUT_NAME property instead of CMAKE_BUILD_TYPE
Diffstat (limited to 'java/test/CMakeLists.txt')
-rw-r--r--java/test/CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/java/test/CMakeLists.txt b/java/test/CMakeLists.txt
index 8912b3f..5c8fa8d 100644
--- a/java/test/CMakeLists.txt
+++ b/java/test/CMakeLists.txt
@@ -88,14 +88,8 @@ endforeach ()
set (CMAKE_JAVA_CLASSPATH "${CMAKE_JAVA_CLASSPATH}${CMAKE_JAVA_INCLUDE_FLAG_SEP}${${HDF5_JAVA_TEST_LIB_TARGET}_JAR_FILE}")
set (testfilter "OK (598 tests)")
-if (CMAKE_BUILD_TYPE MATCHES Debug)
- if (WIN32)
- set (CMD_ARGS "-Dhdf.hdf5lib.H5.loadLibraryName=hdf5_java_D;")
- else ()
- set (CMD_ARGS "-Dhdf.hdf5lib.H5.loadLibraryName=hdf5_java_debug;")
- endif ()
-endif ()
-
+string(TOUPPER ${HDF5_BUILD_TYPE} CMD_BUILD_TYPE)
+set (CMD_ARGS "-Dhdf.hdf5lib.H5.loadLibraryName=$<TARGET_PROPERTY:${HDF5_JAVA_JNI_LIB_TARGET},OUTPUT_NAME_${CMD_BUILD_TYPE}>;")
add_test (
NAME JUnit-interface-clearall-objects
COMMAND ${CMAKE_COMMAND}