summaryrefslogtreecommitdiffstats
path: root/java/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-04-19 18:08:09 (GMT)
committerGitHub <noreply@github.com>2022-04-19 18:08:09 (GMT)
commit03c3a5469542688a52d5a20242d2334408f8ba33 (patch)
tree46e30ea4aa99b68279fe80c9ad56b1a6bbfcfe7c /java/test/CMakeLists.txt
parent32ef796e470da3e4de364d8dc469b03f5f6fafdc (diff)
downloadhdf5-03c3a5469542688a52d5a20242d2334408f8ba33.zip
hdf5-03c3a5469542688a52d5a20242d2334408f8ba33.tar.gz
hdf5-03c3a5469542688a52d5a20242d2334408f8ba33.tar.bz2
Develop clang format java (#1653)
Diffstat (limited to 'java/test/CMakeLists.txt')
-rw-r--r--java/test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/java/test/CMakeLists.txt b/java/test/CMakeLists.txt
index b1186a4..9d1ed2b 100644
--- a/java/test/CMakeLists.txt
+++ b/java/test/CMakeLists.txt
@@ -86,6 +86,13 @@ foreach (test_file ${HDF5_JAVA_TEST_SOURCES})
add_dependencies (${HDF5_JAVA_TEST_LIB_TARGET}_${test_file} ${HDF5_JAVA_HDF5_LIB_TARGET})
set_target_properties (${HDF5_JAVA_TEST_LIB_TARGET}_${test_file} PROPERTIES FOLDER test/java)
+
+ #-----------------------------------------------------------------------------
+ # Add Target to clang-format
+ #-----------------------------------------------------------------------------
+ if (HDF5_ENABLE_FORMATTERS)
+ clang_format (HDF5_JAVA_TEST_${test_file}_SRC_FORMAT ${test_file}.java)
+ endif ()
endforeach ()
foreach (h5_file ${HDF5_JAVA_TEST_SOURCES})