summaryrefslogtreecommitdiffstats
path: root/java/test/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-02-03 19:45:14 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-05-20 14:31:54 (GMT)
commit0bdf289f983fcf286baa9a6693c12f2d12023193 (patch)
treebfdbc91cb4a3a6b5180066572d33aa2596b0a2c3 /java/test/Makefile.am
parent1311f9e999b3be7d12e936af735dd5fc3b11b08d (diff)
downloadhdf5-0bdf289f983fcf286baa9a6693c12f2d12023193.zip
hdf5-0bdf289f983fcf286baa9a6693c12f2d12023193.tar.gz
hdf5-0bdf289f983fcf286baa9a6693c12f2d12023193.tar.bz2
HDFFV-10996 - add java vol tests
Diffstat (limited to 'java/test/Makefile.am')
-rw-r--r--java/test/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/java/test/Makefile.am b/java/test/Makefile.am
index c375938..3f11933 100644
--- a/java/test/Makefile.am
+++ b/java/test/Makefile.am
@@ -84,6 +84,11 @@ noinst_DATA = $(jarfile)
.PHONY: classes
+# Test with just the native connector, with a single pass-through connector
+# and with a doubly-stacked pass-through.
+VOL_LIST = native "pass_through under_vol=0;under_info={}" \
+ "pass_through under_vol=505;under_info={under_vol=0;under_info={}}"
+
check_SCRIPTS = junit.sh
TEST_SCRIPT = $(check_SCRIPTS)