summaryrefslogtreecommitdiffstats
path: root/perform/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-05-12 15:15:27 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-05-12 15:15:27 (GMT)
commit63e372c5699f197d62731cbd279204b2cc1c45ae (patch)
treef3f3d2886693fde39e58d499aa18be0ec50c1891 /perform/Makefile.am
parent6cdadf3db5d57111f80eb45a587af7eb30336dcb (diff)
downloadhdf5-63e372c5699f197d62731cbd279204b2cc1c45ae.zip
hdf5-63e372c5699f197d62731cbd279204b2cc1c45ae.tar.gz
hdf5-63e372c5699f197d62731cbd279204b2cc1c45ae.tar.bz2
[svn-r14969] Purpose: Bug Fix (Bug 1144)
Description: Tests in perform directory were never getting run, and h5perf* programs were not being installed. Solution: Added another build option, 'make check-perform', which runs the tests in the perform directory. Also modified the Makefiles in the perform directory to install (with 'make install') h5perf when parallel is enabled, and h5perf and h5perf_serial when parallel is disabled. Tested: kagiso, smirom, linew
Diffstat (limited to 'perform/Makefile.am')
-rw-r--r--perform/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/perform/Makefile.am b/perform/Makefile.am
index f82def8..f0f35e1 100644
--- a/perform/Makefile.am
+++ b/perform/Makefile.am
@@ -24,7 +24,10 @@ include $(top_srcdir)/config/commence.am
INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/tools/lib
if BUILD_PARALLEL_CONDITIONAL
+ bin_PROGRAMS=h5perf
TEST_PROG_PARA=h5perf perf
+else
+ bin_PROGRAMS=h5perf h5perf_serial
endif
# Some programs are not built or run by default, but can be built by hand or by
@@ -59,4 +62,6 @@ iopipe_LDADD=$(LIBH5TEST) $(LIBHDF5)
zip_perf_LDADD=$(LIBH5TOOLS) $(LIBH5TEST) $(LIBHDF5)
perf_meta_LDADD=$(LIBH5TEST) $(LIBHDF5)
+check-perform: check
+
include $(top_srcdir)/config/conclude.am