summaryrefslogtreecommitdiffstats
path: root/perform/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-07-23 20:04:18 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-07-23 20:04:18 (GMT)
commit6a00b1b6ffe86872088f92f38c98ccd6599d3c6c (patch)
treebab50938ed33e313d37c381b1769ff2a95f15502 /perform/Makefile.am
parent3a8bce5cb845685b9cfb7267ad6addc155dea567 (diff)
downloadhdf5-6a00b1b6ffe86872088f92f38c98ccd6599d3c6c.zip
hdf5-6a00b1b6ffe86872088f92f38c98ccd6599d3c6c.tar.gz
hdf5-6a00b1b6ffe86872088f92f38c98ccd6599d3c6c.tar.bz2
[svn-r17228] Purpose:
Fix BZ #1583 Description: The --enable-static-exec flag was broken. Configure was adding the -all-static linker flag to an environment variable which was subsequently never used. (looks like it was used in 1.6 Makefile.ins, but never moved to 1.8's Makefile.ams when we added automake support). To fix, I've added this environment varibale to the link lines of all the tools. Now, when --enable-static-exec is invoked, it will correctly generate statically linked executables in the installed bin directory. Tested: I've tested manually to ensure that the generated execs are static when the flag is used and dynamic when not. I've also tested when szip is used, as this was a use case mentioned in the bug report. Also: ran full tests with make check on jam and smirom for good measure.
Diffstat (limited to 'perform/Makefile.am')
-rw-r--r--perform/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/perform/Makefile.am b/perform/Makefile.am
index 603175d..255275e 100644
--- a/perform/Makefile.am
+++ b/perform/Makefile.am
@@ -30,6 +30,10 @@ else
bin_PROGRAMS=h5perf_serial
endif
+# Add h5perf and h5perf_serial specific linker flags here
+h5perf_LDFLAGS = $(LT_STATIC_EXEC)
+h5perf_serial_LDFLAGS = $(LT_STATIC_EXEC)
+
# Some programs are not built or run by default, but can be built by hand or by
# specifying --enable-build-all at configure time.
# Also, some of these programs should only be built in parallel.