summaryrefslogtreecommitdiffstats
path: root/perform/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-01-07 16:57:06 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-01-07 16:57:06 (GMT)
commit6ba811adcfb0d0c1dd0cf151020caa3c627f7a7a (patch)
treedcc020c5f3d9f6819f64314d926156a41d6530d6 /perform/Makefile.am
parent16ec39276000b6e06e12dba66bce52e4dba5be04 (diff)
downloadhdf5-6ba811adcfb0d0c1dd0cf151020caa3c627f7a7a.zip
hdf5-6ba811adcfb0d0c1dd0cf151020caa3c627f7a7a.tar.gz
hdf5-6ba811adcfb0d0c1dd0cf151020caa3c627f7a7a.tar.bz2
[svn-r11867] Purpose:
Makefile fix Description: perform/h5perf is (currently) a test for parallel performance, but was being built when parallel was disabled. Fixed this. perform/perf had the same problem. Solution: Actually, perf and h5perf were being "built but not executed" using two different mechansims. They now use the same mechanism, being built and executed in parallel only. Platforms tested: mir, heping, sleipnir
Diffstat (limited to 'perform/Makefile.am')
-rw-r--r--perform/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/perform/Makefile.am b/perform/Makefile.am
index a43e925..3b89e1e 100644
--- a/perform/Makefile.am
+++ b/perform/Makefile.am
@@ -23,13 +23,9 @@ include $(top_srcdir)/config/commence.am
INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/tools/lib
if BUILD_PARALLEL_CONDITIONAL
- TEST_PROG_PARA=h5perf
+ TEST_PROG_PARA=h5perf perf
endif
-# h5perf is run as a test in parallel when parallel is available, but it is
-# always installed with the tools during make install.
-bin_PROGRAMS=h5perf
-
# Some programs are not built or run by default, but can be built by hand or by
# specifying --enable-build-all at configure time.
# Also, some of these programs should only be built in parallel.
@@ -43,7 +39,7 @@ endif
# These are the programs that `make all' or `make tests' will build and which
# `make check' will run. List them in the order they should be run.
TEST_PROG = iopipe chunk overhead zip_perf perf_meta $(BUILD_ALL_PROGS)
-check_PROGRAMS=$(TEST_PROG_PARA) $(TEST_PROG) perf
+check_PROGRAMS=$(TEST_PROG_PARA) $(TEST_PROG)
h5perf_SOURCES=pio_perf.c pio_engine.c pio_timer.c