summaryrefslogtreecommitdiffstats
path: root/perform/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-10-14 22:52:13 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-10-14 22:52:13 (GMT)
commitbcf3f797d442096d4ec5fcbe009b20b84b1adc85 (patch)
treeb8148c7861e75841758a4a173c89979e8de8b06e /perform/Makefile.am
parent1199296120cab95a4ef8de64538d8be3a44b9efe (diff)
downloadhdf5-bcf3f797d442096d4ec5fcbe009b20b84b1adc85.zip
hdf5-bcf3f797d442096d4ec5fcbe009b20b84b1adc85.tar.gz
hdf5-bcf3f797d442096d4ec5fcbe009b20b84b1adc85.tar.bz2
[svn-r11566] Purpose:
Makefile bug fix Description: Previously, automake didn't output rules to build perform/mpi-perf or the test/gen_* programs. Now these can be built by typing 'make mpi-perf' (or 'make foo') or by configuring with --enable-build-all. Solution: Automake doesn't like having rules for programs it doesn't build. Tricked it by having these programs built "sometimes"--whenever the user enables --build-all. This should be used mostly for testing and to ensure that these helper programs compile. ***IMPORTANT*** These programs do *not* currently compile. When --enable-build-all is used (not the default), gen_new_fill fails because it uses an old API. This is an existing "bug" that has simply been exposed by this checkin. Platforms tested: sleipnir, modi4, sol Misc. update:
Diffstat (limited to 'perform/Makefile.am')
-rw-r--r--perform/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/perform/Makefile.am b/perform/Makefile.am
index 1dd98b0..c10a80e 100644
--- a/perform/Makefile.am
+++ b/perform/Makefile.am
@@ -30,9 +30,17 @@ endif
# always installed with the tools during make install.
bin_PROGRAMS=h5perf
+# mpi-perf is not built or run by default, but can be built by hand or by
+# specifying --enable-build-all at configure time.
+if BUILD_ALL_CONDITIONAL
+ MPI_PERF=mpi-perf
+else
+ MPI_PERF=
+endif
+
# These are the programs that `make all' or `make tests' will build and which
# `make check' will run. List them in the order they should be run.
-TEST_PROG = iopipe chunk overhead zip_perf perf_meta
+TEST_PROG = iopipe chunk overhead zip_perf perf_meta $(MPI_PERF)
check_PROGRAMS=$(TEST_PROG_PARA) $(TEST_PROG) perf
h5perf_SOURCES=pio_perf.c pio_engine.c pio_timer.c