summaryrefslogtreecommitdiffstats
path: root/perform/Makefile.am
diff options
context:
space:
mode:
authorChristian Chilan <chilan@hdfgroup.org>2008-04-10 22:36:51 (GMT)
committerChristian Chilan <chilan@hdfgroup.org>2008-04-10 22:36:51 (GMT)
commitec1cd05cf65e52a9a75f6bbf7b4c20f10ecc58a8 (patch)
tree5482e0aeecabcda847c141b3fcffa09dce45446a /perform/Makefile.am
parent66bb19b12fd951c8a277416f281d0ac3c0d634e0 (diff)
downloadhdf5-ec1cd05cf65e52a9a75f6bbf7b4c20f10ecc58a8.zip
hdf5-ec1cd05cf65e52a9a75f6bbf7b4c20f10ecc58a8.tar.gz
hdf5-ec1cd05cf65e52a9a75f6bbf7b4c20f10ecc58a8.tar.bz2
[svn-r14827] Makefiles configured to build and test the serial benchmarking tool.
Tested on kagiso, smirom, and linew.
Diffstat (limited to 'perform/Makefile.am')
-rw-r--r--perform/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/perform/Makefile.am b/perform/Makefile.am
index e2c5822..f82def8 100644
--- a/perform/Makefile.am
+++ b/perform/Makefile.am
@@ -39,10 +39,11 @@ endif
# These are the programs that `make all' or `make tests' will build and which
# `make check' will run. List them in the order they should be run.
-TEST_PROG = iopipe chunk overhead zip_perf perf_meta $(BUILD_ALL_PROGS)
+TEST_PROG = iopipe chunk overhead zip_perf perf_meta h5perf_serial $(BUILD_ALL_PROGS)
check_PROGRAMS=$(TEST_PROG_PARA) $(TEST_PROG)
h5perf_SOURCES=pio_perf.c pio_engine.c pio_timer.c
+h5perf_serial_SOURCES=sio_perf.c sio_engine.c sio_timer.c
# These are the files that `make clean' (and derivatives) will remove from
# this directory.
@@ -52,6 +53,7 @@ CLEANFILES=*.h5 *.raw *.dat x-gnuplot
# depend on test or tools library.
LDADD=$(LIBHDF5)
h5perf_LDADD=$(LIBH5TOOLS) $(LIBH5TEST) $(LIBHDF5)
+h5perf_serial_LDADD=$(LIBH5TOOLS) $(LIBH5TEST) $(LIBHDF5)
perf_LDADD=$(LIBH5TEST) $(LIBHDF5)
iopipe_LDADD=$(LIBH5TEST) $(LIBHDF5)
zip_perf_LDADD=$(LIBH5TOOLS) $(LIBH5TEST) $(LIBHDF5)