summaryrefslogtreecommitdiffstats
path: root/perform/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-10-24 18:58:15 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-10-24 18:58:15 (GMT)
commit8619af74a4bc5013d6c9896f1c696f91e7bda050 (patch)
tree7a2985911cb2a18caf9b7e3555bbd390e6cb3190 /perform/Makefile.am
parentd2f2b5090cec5a75697dd5db04ede7ee0fa6d687 (diff)
downloadhdf5-8619af74a4bc5013d6c9896f1c696f91e7bda050.zip
hdf5-8619af74a4bc5013d6c9896f1c696f91e7bda050.tar.gz
hdf5-8619af74a4bc5013d6c9896f1c696f91e7bda050.tar.bz2
[svn-r11601] Purpose:
Added additional targets to build-all Description: Surveyed files to find out which ones are not built. Added test/space_overflow and perform/benchpar to programs built with --enable-build-all. Discovered that tools/misc/pdb2hdf5 and tools/misc/h5import were obsolete and deleted them. Platforms tested: mir, modi4, sol Misc. update: Update of release file and removal of --enable-pdb2hdf5 to follow.
Diffstat (limited to 'perform/Makefile.am')
-rw-r--r--perform/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/perform/Makefile.am b/perform/Makefile.am
index c10a80e..a43e925 100644
--- a/perform/Makefile.am
+++ b/perform/Makefile.am
@@ -30,17 +30,19 @@ endif
# always installed with the tools during make install.
bin_PROGRAMS=h5perf
-# mpi-perf is not built or run by default, but can be built by hand or by
+# Some programs are not built or run by default, but can be built by hand or by
# specifying --enable-build-all at configure time.
+# Also, some of these programs should only be built in parallel.
+if BUILD_PARALLEL_CONDITIONAL
+ PARA_BUILD_ALL=benchpar mpi-perf
+endif
if BUILD_ALL_CONDITIONAL
- MPI_PERF=mpi-perf
-else
- MPI_PERF=
+ BUILD_ALL_PROGS=$(PARA_BUILD_ALL)
endif
# These are the programs that `make all' or `make tests' will build and which
# `make check' will run. List them in the order they should be run.
-TEST_PROG = iopipe chunk overhead zip_perf perf_meta $(MPI_PERF)
+TEST_PROG = iopipe chunk overhead zip_perf perf_meta $(BUILD_ALL_PROGS)
check_PROGRAMS=$(TEST_PROG_PARA) $(TEST_PROG) perf
h5perf_SOURCES=pio_perf.c pio_engine.c pio_timer.c