summaryrefslogtreecommitdiffstats
path: root/perform/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-05-12 14:48:32 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-05-12 14:48:32 (GMT)
commit7e7e7c7aef2a800cda8fc44daa64fd388416a646 (patch)
tree6cd23986e1e5936d863ec40e0c2c2881184e7291 /perform/Makefile.am
parentc48f37b3272655b1adae1bb0b0b00ade75f42071 (diff)
downloadhdf5-7e7e7c7aef2a800cda8fc44daa64fd388416a646.zip
hdf5-7e7e7c7aef2a800cda8fc44daa64fd388416a646.tar.gz
hdf5-7e7e7c7aef2a800cda8fc44daa64fd388416a646.tar.bz2
[svn-r14968] Purpose: Bug Fix (Bug 1144)
Description: Tests in perform directory were never getting run, and h5perf* programs were not being installed. Solution: Added another build option, 'make check-perform', which runs the tests in the perform directory. Also modified the Makefiles in the perform directory to install (with 'make install') h5perf when parallel is enabled, and h5perf and h5perf_serial when parallel is disabled Tested: kagiso, smirom, linew
Diffstat (limited to 'perform/Makefile.am')
-rw-r--r--perform/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/perform/Makefile.am b/perform/Makefile.am
index f82def8..f0f35e1 100644
--- a/perform/Makefile.am
+++ b/perform/Makefile.am
@@ -24,7 +24,10 @@ include $(top_srcdir)/config/commence.am
INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/tools/lib
if BUILD_PARALLEL_CONDITIONAL
+ bin_PROGRAMS=h5perf
TEST_PROG_PARA=h5perf perf
+else
+ bin_PROGRAMS=h5perf h5perf_serial
endif
# Some programs are not built or run by default, but can be built by hand or by
@@ -59,4 +62,6 @@ iopipe_LDADD=$(LIBH5TEST) $(LIBHDF5)
zip_perf_LDADD=$(LIBH5TOOLS) $(LIBH5TEST) $(LIBHDF5)
perf_meta_LDADD=$(LIBH5TEST) $(LIBHDF5)
+check-perform: check
+
include $(top_srcdir)/config/conclude.am