summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2021-06-18 13:42:23 (GMT)
committerGitHub <noreply@github.com>2021-06-18 13:42:23 (GMT)
commit2e80c9cdec98d6cee5b4609643839a4ad2a848fb (patch)
tree8138b57615d3d983fc1be26e739a834410b25d67 /src/CMakeLists.txt
parent1e29bcbfe24956f0158b3363a3fbb8a42c8e7e0f (diff)
downloadhdf5-2e80c9cdec98d6cee5b4609643839a4ad2a848fb.zip
hdf5-2e80c9cdec98d6cee5b4609643839a4ad2a848fb.tar.gz
hdf5-2e80c9cdec98d6cee5b4609643839a4ad2a848fb.tar.bz2
Brings hash table IDs feature from develop/1.12 (#768)
* Brings updated tid test from develop * Adds empty H5Iint.c and H5Idbg.c files * H5I renaming to match 1.12/develop * Splits off H5I debug code to H5Idbg.c * Splits internal H5I.c functionality to H5Iint.c * Header cleanup * More renaming cleanup to match develop/1.12 * Adds "save last ID" optimization * Adds uthash.h * Adds hash table IDs from develop/1.12 * Committing clang-format changes Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ac6d65a..f19c62a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -372,6 +372,8 @@ IDE_GENERATED_PROPERTIES ("H5HP" "${H5HP_HDRS}" "${H5HP_SOURCES}" )
set (H5I_SOURCES
${HDF5_SRC_DIR}/H5I.c
+ ${HDF5_SRC_DIR}/H5Idbg.c
+ ${HDF5_SRC_DIR}/H5Iint.c
${HDF5_SRC_DIR}/H5Itest.c
)
set (H5I_HDRS
@@ -904,6 +906,8 @@ set (H5_PRIVATE_HEADERS
${HDF5_SRC_DIR}/H5Zprivate.h
${HDF5_SRC_DIR}/H5win32defs.h
+
+ ${HDF5_SRC_DIR}/uthash.h
)
set (H5_GENERATED_HEADERS