summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-10-11 17:24:15 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-10-11 17:24:15 (GMT)
commit4659e43a6b0914e3da6048328cece6e01be95e44 (patch)
treef917242512f4c14d121d34130a6262fe2a3b9301 /src/CMakeLists.txt
parentd69b541c2009e534d746622345268595b2ca614c (diff)
downloadhdf5-4659e43a6b0914e3da6048328cece6e01be95e44.zip
hdf5-4659e43a6b0914e3da6048328cece6e01be95e44.tar.gz
hdf5-4659e43a6b0914e3da6048328cece6e01be95e44.tar.bz2
HDFFV-10603 fixup cmake usage
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 49a84df..5314697 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -895,7 +895,7 @@ if (NOT EXISTS ${HDF5_GENERATED_SOURCE_DIR}/H5Tinit.c)
TARGET_C_PROPERTIES (H5detect STATIC)
target_link_libraries (H5detect
PRIVATE "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>" $<$<PLATFORM_ID:Windows>:ws2_32.lib>
- INTERFACE $<$<PLATFORM_ID:Emscripten>:"-O0">
+ PRIVATE $<$<PLATFORM_ID:Emscripten>:"-O0">
)
option (HDF5_BATCH_DETECT "Use batch file to execute H5detect" OFF)
@@ -956,7 +956,7 @@ target_compile_definitions(H5make_libsettings PUBLIC ${HDF_EXTRA_C_FLAGS} ${HDF_
TARGET_C_PROPERTIES (H5make_libsettings STATIC)
target_link_libraries (H5make_libsettings
PRIVATE "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_LIBRARIES}>" $<$<PLATFORM_ID:Windows>:ws2_32.lib>
- INTERFACE $<$<PLATFORM_ID:Emscripten>:"-O0">
+ PRIVATE $<$<PLATFORM_ID:Emscripten>:"-O0">
)
add_custom_command (