summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2018-12-20 01:41:50 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2018-12-20 01:41:50 (GMT)
commit9cfe7fd18d01d6fc84ac2e8902c955452b64259d (patch)
tree4318aa257e2661a8af825fe635ad3bc2dcea1ddb /src/CMakeLists.txt
parent9fba6e082cefef51f66cf3d2338ecccadbe69fc8 (diff)
downloadhdf5-9cfe7fd18d01d6fc84ac2e8902c955452b64259d.zip
hdf5-9cfe7fd18d01d6fc84ac2e8902c955452b64259d.tar.gz
hdf5-9cfe7fd18d01d6fc84ac2e8902c955452b64259d.tar.bz2
Split the native VOL connector code into multiple files and
moved the attribute code over.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 778505f..bac113a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -628,6 +628,13 @@ set (H5VL_SOURCES
${HDF5_SRC_DIR}/H5VLcallback.c
${HDF5_SRC_DIR}/H5VLint.c
${HDF5_SRC_DIR}/H5VLnative.c
+ ${HDF5_SRC_DIR}/H5VLnative_attr.c
+ ${HDF5_SRC_DIR}/H5VLnative_dataset.c
+ ${HDF5_SRC_DIR}/H5VLnative_datatype.c
+ ${HDF5_SRC_DIR}/H5VLnative_file.c
+ ${HDF5_SRC_DIR}/H5VLnative_group.c
+ ${HDF5_SRC_DIR}/H5VLnative_link.c
+ ${HDF5_SRC_DIR}/H5VLnative_object.c
${HDF5_SRC_DIR}/H5VLpassthru.c
)
set (H5VL_HDRS