summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2011-07-20 22:25:51 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2011-07-20 22:25:51 (GMT)
commita42f3b9ddaca2f2d566f38bebdd419a3c941669a (patch)
tree25a72d07ec797cefb5364ea6baf17818f5ffe1a5 /src/CMakeLists.txt
parent7beed66358ff6c3d664526bc6e7b9d5990238331 (diff)
downloadhdf5-a42f3b9ddaca2f2d566f38bebdd419a3c941669a.zip
hdf5-a42f3b9ddaca2f2d566f38bebdd419a3c941669a.tar.gz
hdf5-a42f3b9ddaca2f2d566f38bebdd419a3c941669a.tar.bz2
[svn-r21134] Description:
Bring r21133 from trunk to 1.8 branch: More code cleanups to reduce coupling between packages that use the H5F internal routines, but really aren't part of the H5F "package". Tested on: FreeBSD/32 8.2 (loyalty) w/gcc4.6, w/C++ & FORTRAN, in debug mode FreeBSD/64 8.2 (freedom) w/gcc4.6, w/C++ & FORTRAN, in debug mode Linux/32 2.6 (jam) w/PGI compilers, w/default API=1.8.x, w/C++ & FORTRAN, w/threadsafe, in debug mode Linux/64-amd64 2.6 (koala) w/Intel compilers, w/default API=1.6.x, w/C++ & FORTRAN, in production mode Solaris/32 2.10 (linew) w/deprecated symbols disabled, w/C++ & FORTRAN, w/szip filter, w/threadsafe, in production mode Linux/PPC 2.6 (heiwa) w/C++ & FORTRAN, w/threadsafe, in debug mode
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 32421b7..d4df2b9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -113,6 +113,7 @@ IDE_GENERATED_PROPERTIES ("H5E" "${H5E_HDRS}" "${H5E_SRCS}" )
SET (H5F_SRCS
${HDF5_SRC_DIR}/H5F.c
${HDF5_SRC_DIR}/H5Faccum.c
+ ${HDF5_SRC_DIR}/H5Fcwfs.c
${HDF5_SRC_DIR}/H5Fdbg.c
${HDF5_SRC_DIR}/H5Fefc.c
${HDF5_SRC_DIR}/H5Ffake.c
@@ -235,6 +236,7 @@ SET (H5HG_SRCS
${HDF5_SRC_DIR}/H5HG.c
${HDF5_SRC_DIR}/H5HGcache.c
${HDF5_SRC_DIR}/H5HGdbg.c
+ ${HDF5_SRC_DIR}/H5HGquery.c
)
SET (H5HG_HDRS