summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2023-07-30 01:21:51 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2023-07-30 01:21:51 (GMT)
commita8bd57253ee0da6b8ae875b820e9b34e18c09c0e (patch)
treefae9afe4e9e46778550fb2272a97893dbd5c77e5 /src/CMakeLists.txt
parenta2bd42d9f2752a5de7eb92216624cdb63663ba51 (diff)
downloadhdf5-a8bd57253ee0da6b8ae875b820e9b34e18c09c0e.zip
hdf5-a8bd57253ee0da6b8ae875b820e9b34e18c09c0e.tar.gz
hdf5-a8bd57253ee0da6b8ae875b820e9b34e18c09c0e.tar.bz2
Initial changes for HDF5 1.14.2 release
Update configure.ac for release: switch configure default to production mode, disable maintainer mode. Set HDF5_GENERATE_HEADERS to OFF in src/CMakeLists.txt. Generate release files with autogen.sh, autoconf 2.71 and automake 1.16.2.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 92c74f7..d056563 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -991,7 +991,7 @@ set (H5_PUBLIC_GENERATED_HEADERS
${HDF5_SRC_DIR}/H5overflow.h
)
-option (HDF5_GENERATE_HEADERS "Rebuild Generated Files" ON)
+option (HDF5_GENERATE_HEADERS "Rebuild Generated Files" OFF)
if (HDF5_GENERATE_HEADERS)
set_source_files_properties(${H5_GENERATED_HEADERS} PROPERTIES GENERATED TRUE)
if (H5_PERL_FOUND)