summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2019-08-14 23:22:06 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2019-08-14 23:22:06 (GMT)
commitbd8da502cf5b763433e3c628a4043a4264529cec (patch)
tree452da55063d4a6c6d7ea585826e67e416dcaaf02 /src/CMakeLists.txt
parent2b72832d97496290f74ccaffcda41c3e596f8f49 (diff)
downloadhdf5-bd8da502cf5b763433e3c628a4043a4264529cec.zip
hdf5-bd8da502cf5b763433e3c628a4043a4264529cec.tar.gz
hdf5-bd8da502cf5b763433e3c628a4043a4264529cec.tar.bz2
Some refactoring prior to implementing new H5P MPI functions.
* Macro cleanup and obvious warning fixes in parallel code. * Moved H5FD comm and info dup/free wrapper code to a new H5mpi.c file and separated it to deal with each MPI type separately.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 17fd949..313d231 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -8,6 +8,7 @@ set (H5_SOURCES
${HDF5_SRC_DIR}/H5.c
${HDF5_SRC_DIR}/H5checksum.c
${HDF5_SRC_DIR}/H5dbg.c
+ ${HDF5_SRC_DIR}/H5mpi.c
${HDF5_SRC_DIR}/H5system.c
${HDF5_SRC_DIR}/H5timer.c
${HDF5_SRC_DIR}/H5trace.c