summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-03-30 17:32:55 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-03-30 17:32:55 (GMT)
commitc923afdf50173d8fd80d252375eb01f3eb8fdf8e (patch)
treeed93d0ead945d4f5c5115e76134639ba7ba11865 /src/CMakeLists.txt
parent6a664ffa5aba85eb2d35526fa9d41a5b69f7f21d (diff)
downloadhdf5-c923afdf50173d8fd80d252375eb01f3eb8fdf8e.zip
hdf5-c923afdf50173d8fd80d252375eb01f3eb8fdf8e.tar.gz
hdf5-c923afdf50173d8fd80d252375eb01f3eb8fdf8e.tar.bz2
[svn-r26654] Bring trunk CMake changes to branch.
Tested: local linux
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e98066d..0e97ba0 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -611,7 +611,7 @@ set (H5_PRIVATE_HEADERS
# specific type checks inside
#-----------------------------------------------------------------------------
add_executable (H5detect ${HDF5_SRC_DIR}/H5detect.c)
-TARGET_C_PROPERTIES (H5detect ${LIB_TYPE} " " " ")
+TARGET_C_PROPERTIES (H5detect STATIC " " " ")
if (MSVC OR MINGW)
target_link_libraries (H5detect "ws2_32.lib")
endif (MSVC OR MINGW)
@@ -625,7 +625,7 @@ add_custom_command (
)
add_executable (H5make_libsettings ${HDF5_SRC_DIR}/H5make_libsettings.c)
-TARGET_C_PROPERTIES (H5make_libsettings ${LIB_TYPE} " " " ")
+TARGET_C_PROPERTIES (H5make_libsettings STATIC " " " ")
if (MSVC OR MINGW)
target_link_libraries (H5make_libsettings "ws2_32.lib")
endif (MSVC OR MINGW)