summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2019-05-24 00:56:27 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2019-05-24 09:22:08 (GMT)
commitd5a8b2a80cd1e5aaa62a523e03a5936260a56f60 (patch)
tree7b3076c1cf79633dc0d67cc37b4aa5994ebb0c2b /src/CMakeLists.txt
parente1879a23ae414e5256bcc0170f40784cd698af89 (diff)
downloadhdf5-d5a8b2a80cd1e5aaa62a523e03a5936260a56f60.zip
hdf5-d5a8b2a80cd1e5aaa62a523e03a5936260a56f60.tar.gz
hdf5-d5a8b2a80cd1e5aaa62a523e03a5936260a56f60.tar.bz2
Split VOL connector routines into separate headers:
* H5VLconnector.h for terminal connector things * H5VLconnector_passthru.h for passthrough connector things Note that these headers are arranged such that they are included in hdf5.h so VOL connectors only need to include that. The separation into multiple headers is mainly for readability.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9730436..fbaba34 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -640,6 +640,8 @@ set (H5VL_SOURCES
${HDF5_SRC_DIR}/H5VLpassthru.c
)
set (H5VL_HDRS
+ ${HDF5_SRC_DIR}/H5VLconnector.h
+ ${HDF5_SRC_DIR}/H5VLconnector_passthru.h
${HDF5_SRC_DIR}/H5VLnative.h
${HDF5_SRC_DIR}/H5VLpassthru.h
${HDF5_SRC_DIR}/H5VLpublic.h