summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-02-22 14:36:28 (GMT)
committerGitHub <noreply@github.com>2022-02-22 14:36:28 (GMT)
commit5a5a77040225a5c621cb75b578204c8b534a7652 (patch)
treeff672da41ac40aede50895b8e514b6d4c30e9f9a /src/CMakeLists.txt
parent3107fafa2ce858b598617463334d3d6d01dc1e4c (diff)
downloadhdf5-5a5a77040225a5c621cb75b578204c8b534a7652.zip
hdf5-5a5a77040225a5c621cb75b578204c8b534a7652.tar.gz
hdf5-5a5a77040225a5c621cb75b578204c8b534a7652.tar.bz2
Enable creation of RPM/DEB binaries GH#1394 (#1398)
Co-authored-by: Larry Knox <lrknox@hdfgroup.org>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index da99dc6..017b5d6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1329,6 +1329,7 @@ if (HDF5_EXPORTED_TARGETS)
RUNTIME DESTINATION ${HDF5_INSTALL_BIN_DIR} COMPONENT libraries
FRAMEWORK DESTINATION ${HDF5_INSTALL_FWRK_DIR} COMPONENT libraries
INCLUDES DESTINATION include
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
)
endif ()