summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorjhendersonHDF <jhenderson@hdfgroup.org>2023-07-13 17:19:02 (GMT)
committerGitHub <noreply@github.com>2023-07-13 17:19:02 (GMT)
commit26059fc7abd51827d0e7a798fac1cfa7461db7d3 (patch)
treed429feaa8d22f72f7415330c895d2562f405e46d /src/CMakeLists.txt
parentb77d5bacea7f004153b2752a9cb17d26ae975cf9 (diff)
downloadhdf5-26059fc7abd51827d0e7a798fac1cfa7461db7d3.zip
hdf5-26059fc7abd51827d0e7a798fac1cfa7461db7d3.tar.gz
hdf5-26059fc7abd51827d0e7a798fac1cfa7461db7d3.tar.bz2
Subfiling VFD source cleanup (#3241)
* Subfiling VFD source cleanup Modularize Subfiling CMake code into separate CMakeLists.txt file Update Mercury util code to latest version and update Copyright Generate mercury_util_config.h header file instead of using pre-generated file Remove unnecessary Mercury functionality Fix minor warning in Subfiling VFD code * Remove Mercury headers from Autotools publicly-distributed header list
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt25
1 files changed, 1 insertions, 24 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cf23f1f..f12b079 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -278,33 +278,11 @@ set (H5FD_HDRS
${HDF5_SRC_DIR}/H5FDsplitter.h
${HDF5_SRC_DIR}/H5FDstdio.h
${HDF5_SRC_DIR}/H5FDwindows.h
- ${H5FD_SUBFILING_DIR}/H5FDsubfiling.h
- ${H5FD_SUBFILING_DIR}/H5FDioc.h
)
# Append Subfiling VFD and Mercury sources to H5FD interface if Subfiling VFD is built
if (HDF5_ENABLE_SUBFILING_VFD)
- set (MERCURY_UTIL_SOURCES
- ${H5FD_SUBFILING_DIR}/mercury/src/util/mercury_dlog.c
- ${H5FD_SUBFILING_DIR}/mercury/src/util/mercury_log.c
- ${H5FD_SUBFILING_DIR}/mercury/src/util/mercury_thread.c
- ${H5FD_SUBFILING_DIR}/mercury/src/util/mercury_thread_condition.c
- ${H5FD_SUBFILING_DIR}/mercury/src/util/mercury_thread_pool.c
- ${H5FD_SUBFILING_DIR}/mercury/src/util/mercury_thread_mutex.c
- ${H5FD_SUBFILING_DIR}/mercury/src/util/mercury_util.c
- )
-
- set (H5FD_SUBFILING_SOURCES
- ${H5FD_SUBFILING_DIR}/H5FDioc.c
- ${H5FD_SUBFILING_DIR}/H5FDioc_int.c
- ${H5FD_SUBFILING_DIR}/H5FDioc_threads.c
- ${H5FD_SUBFILING_DIR}/H5FDsubfiling.c
- ${H5FD_SUBFILING_DIR}/H5FDsubfile_int.c
- ${H5FD_SUBFILING_DIR}/H5subfiling_common.c
- ${MERCURY_UTIL_SOURCES}
- )
-
- list (APPEND H5FD_SOURCES ${H5FD_SUBFILING_SOURCES})
+ add_subdirectory (${H5FD_SUBFILING_DIR})
endif()
IDE_GENERATED_PROPERTIES ("H5FD" "${H5FD_HDRS}" "${H5FD_SOURCES}" )
@@ -864,7 +842,6 @@ set (H5_PUBLIC_HEADERS
${H5TS_HDRS}
${H5VL_HDRS}
${H5Z_HDRS}
- ${subfile_HDRS}
)
set (H5_PRIVATE_HEADERS