summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorNeil Fortner <nfortne2@hdfgroup.org>2013-09-27 15:35:44 (GMT)
committerNeil Fortner <nfortne2@hdfgroup.org>2013-09-27 15:35:44 (GMT)
commitcd90900d88d2baaf4ef3b4ad6aa30af64a4581cd (patch)
treef2ce465f1da740f4b6cb9a5711d051b49473ad6a /src/CMakeLists.txt
parentb3b29e4485dbdf4eef82f71da8f5b6a5e2509b8e (diff)
downloadhdf5-cd90900d88d2baaf4ef3b4ad6aa30af64a4581cd.zip
hdf5-cd90900d88d2baaf4ef3b4ad6aa30af64a4581cd.tar.gz
hdf5-cd90900d88d2baaf4ef3b4ad6aa30af64a4581cd.tar.bz2
[svn-r24209] Port r24171 from trunk to 1.8 branch.
Tested: jam, koala, ostrich, platypus (h5committest) Log from r24171: Purpose: Fix problem with gcc 4.8 Description: With optimization enabled, gcc 4.8 inserts garbage into the padding bytes of floating point types when assigning from a literal constant. This caused problems when H5detect.c scanned the bits in floating point types to determine their properties. Modified H5detect.c to scan for padding before further analyzing the type, and to ignore all information in the padding areas. Also removed code that temporarily disabled optimization. Tested: jam, koala, ostrich, platypus (h5committest)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7439977..64d5e87 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -613,13 +613,8 @@ INCLUDE_DIRECTORIES (${CMAKE_BINARY_DIR})
# Setup the H5Detect utility which generates H5Tinit with platform
# specific type checks inside
#-----------------------------------------------------------------------------
-IF (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
- SET (LOCAL_OPT_FLAG "-O0")
-ELSE (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
- SET (LOCAL_OPT_FLAG " ")
-ENDIF (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
ADD_EXECUTABLE (H5detect ${HDF5_SRC_DIR}/H5detect.c)
-TARGET_C_PROPERTIES (H5detect ${LOCAL_OPT_FLAG} " ")
+TARGET_C_PROPERTIES (H5detect " " " ")
IF (MSVC)
TARGET_LINK_LIBRARIES (H5detect "ws2_32.lib")
ENDIF (MSVC)