summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-01-19 22:39:23 (GMT)
committerGitHub <noreply@github.com>2021-01-19 22:39:23 (GMT)
commita0ee1eb5dc7ad3f45860eb5ea0791a4380302ddf (patch)
tree1a88b6615ef1e6f281ce4e34c66c393a3193f5e2 /src/CMakeLists.txt
parenta63a1c8a57bd313a0f63c3f39fc18965500c304f (diff)
downloadhdf5-a0ee1eb5dc7ad3f45860eb5ea0791a4380302ddf.zip
hdf5-a0ee1eb5dc7ad3f45860eb5ea0791a4380302ddf.tar.gz
hdf5-a0ee1eb5dc7ad3f45860eb5ea0791a4380302ddf.tar.bz2
1 12 merge of changes from dev (#271)
* OESS-98 fix tools test for plugins * sync fork * Merge of changes from dev * Move problem option to bottom of the list until fixed * HDFFV-11106 - fix parsing optional args * HDFFV-11106 add note * grammer fix
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b15ca06..d7a62ec 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -440,6 +440,7 @@ set (H5MP_HDRS
)
IDE_GENERATED_PROPERTIES ("H5MP" "${H5MP_HDRS}" "${H5MP_SOURCES}" )
+
set (H5O_SOURCES
${HDF5_SRC_DIR}/H5O.c
${HDF5_SRC_DIR}/H5Oainfo.c
@@ -1003,7 +1004,7 @@ if (HDF5_GENERATE_HEADERS)
)
message(STATUS ${SCRIPT_OUTPUT})
else ()
- message (STATUS "Cannot generate headers - perl not found")
+ message (WARNING "Cannot generate headers - perl not found")
endif ()
endif ()
@@ -1335,7 +1336,7 @@ set (_PKG_CONFIG_REQUIRES)
set (_PKG_CONFIG_REQUIRES_PRIVATE)
configure_file (
- ${HDF_RESOURCES_DIR}/libhdf5.pc.in
+ ${HDF_CONFIG_DIR}/libhdf5.pc.in
${HDF5_BINARY_DIR}/CMakeFiles/${HDF5_LIB_CORENAME}-${HDF5_PACKAGE_VERSION}.pc
@ONLY
)