summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMohamad Chaarawi <chaarawi@hdfgroup.org>2013-08-30 17:05:42 (GMT)
committerMohamad Chaarawi <chaarawi@hdfgroup.org>2013-08-30 17:05:42 (GMT)
commita3e0aecb2235e487eae80de4dd4c074bd2dabc0f (patch)
tree78599452e6871eca8e444b5878efc6b9b1076a9b /src/CMakeLists.txt
parent7a0f38d807b4f8b10608dd0d860b625d98845498 (diff)
downloadhdf5-a3e0aecb2235e487eae80de4dd4c074bd2dabc0f.zip
hdf5-a3e0aecb2235e487eae80de4dd4c074bd2dabc0f.tar.gz
hdf5-a3e0aecb2235e487eae80de4dd4c074bd2dabc0f.tar.bz2
[svn-r24087] Rename the private H5RC (reference count) module to H5UC (Use Count).
This is needed to avoid a conflict with the Read Context object to be introduced in another Project. No impact on users, since this is a private module, and low for developers as the RC module use is very sparse in the library. Tested with h5committest.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 91872af..8e7a3bf 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -498,12 +498,12 @@ SET (H5R_HDRS
IDE_GENERATED_PROPERTIES ("H5R" "${H5R_HDRS}" "${H5R_SRCS}" )
-SET (H5RC_SRCS
- ${HDF5_SRC_DIR}/H5RC.c
+SET (H5UC_SRCS
+ ${HDF5_SRC_DIR}/H5UC.c
)
-SET (H5RC_HDRS
+SET (H5UC_HDRS
)
-IDE_GENERATED_PROPERTIES ("H5RC" "${H5RC_HDRS}" "${H5RC_SRCS}" )
+IDE_GENERATED_PROPERTIES ("H5UC" "${H5UC_HDRS}" "${H5UC_SRCS}" )
SET (H5RS_SRCS
@@ -673,7 +673,7 @@ SET (common_SRCS
${H5P_SRCS}
${H5PL_SRCS}
${H5R_SRCS}
- ${H5RC_SRCS}
+ ${H5UC_SRCS}
${H5RS_SRCS}
${H5S_SRCS}
${H5SL_SRCS}
@@ -751,7 +751,7 @@ SET (H5_PRIVATE_HEADERS
${HDF5_SRC_DIR}/H5Oprivate.h
${HDF5_SRC_DIR}/H5Pprivate.h
${HDF5_SRC_DIR}/H5PLprivate.h
- ${HDF5_SRC_DIR}/H5RCprivate.h
+ ${HDF5_SRC_DIR}/H5UCprivate.h
${HDF5_SRC_DIR}/H5Rprivate.h
${HDF5_SRC_DIR}/H5RSprivate.h
${HDF5_SRC_DIR}/H5SLprivate.h