summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorNeil Fortner <nfortne2@hdfgroup.org>2013-09-19 18:57:41 (GMT)
committerNeil Fortner <nfortne2@hdfgroup.org>2013-09-19 18:57:41 (GMT)
commitbe3a33155025d6ef2d57533b60b96c888ab314a6 (patch)
tree2becf1264da71c35b6942b5858704f85cd8f189d /src/CMakeLists.txt
parent0653325f0d4a92164842bb30b797f130e44cbc68 (diff)
downloadhdf5-be3a33155025d6ef2d57533b60b96c888ab314a6.zip
hdf5-be3a33155025d6ef2d57533b60b96c888ab314a6.tar.gz
hdf5-be3a33155025d6ef2d57533b60b96c888ab314a6.tar.bz2
[svn-r24171] Purpose: Fix problem with gcc 4.8
Description: With optimization enabled, gcc 4.8 inserts garbage into the padding bytes of floating point types when assigning from a literal constant. This caused problems when H5detect.c scanned the bits in floating point types to determine their properties. Modified H5detect.c to scan for padding before further analyzing the type, and to ignore all information in the padding areas. Also removed code that temporarily disabled optimization. Tested: jam, koala, ostrich, platypus (h5committest)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8e7a3bf..718a41f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -773,13 +773,8 @@ INCLUDE_DIRECTORIES (${CMAKE_BINARY_DIR})
# Setup the H5Detect utility which generates H5Tinit with platform
# specific type checks inside
#-----------------------------------------------------------------------------
-IF (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
- SET (LOCAL_OPT_FLAG "-O0")
-ELSE (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
- SET (LOCAL_OPT_FLAG " ")
-ENDIF (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
ADD_EXECUTABLE (H5detect ${HDF5_SRC_DIR}/H5detect.c)
-TARGET_C_PROPERTIES (H5detect ${LOCAL_OPT_FLAG} " ")
+TARGET_C_PROPERTIES (H5detect " " " ")
IF (MSVC)
TARGET_LINK_LIBRARIES (H5detect "ws2_32.lib")
ENDIF (MSVC)