summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-05-25 16:00:56 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-05-25 16:00:56 (GMT)
commitef292895e9817f7134da9d4a6c7c0c699e01ae9e (patch)
treee488dfbd24af16f0dfc6ffdf518059cfa775271f /src/CMakeLists.txt
parent9f5a4ed901da65a3b5a6b63f75c99a5fe72c6832 (diff)
downloadhdf5-ef292895e9817f7134da9d4a6c7c0c699e01ae9e.zip
hdf5-ef292895e9817f7134da9d4a6c7c0c699e01ae9e.tar.gz
hdf5-ef292895e9817f7134da9d4a6c7c0c699e01ae9e.tar.bz2
[svn-r18890] Update CMake fortran configure/build with changes from community.
- Add an install rule to copy compiled fortran module files - Only build the xlatefile utility if testing and tools are enabled - Don't do MPI HAVE_XXX checks until MPI_FOUND is true - Install needs H5version.h & H5overflow.h to be copied - Add debug information flags to debug compile and link lines for win32 Intel compiler
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 506ca80..4a1c5c8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -17,6 +17,8 @@ SET (H5_HDRS
${HDF5_SRC_DIR}/hdf5.h
${HDF5_SRC_DIR}/H5api_adpt.h
${HDF5_SRC_DIR}/H5public.h
+ ${HDF5_SRC_DIR}/H5version.h
+ ${HDF5_SRC_DIR}/H5overflow.h
)
IDE_GENERATED_PROPERTIES ("H5" "${H5_HDRS}" "${H5_SRCS}" )