summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@koziol.gov>2019-08-21 18:14:06 (GMT)
committerJerome Soumagne <jsoumagne@hdfgroup.org>2019-10-08 20:18:27 (GMT)
commitff490b4a69029fa75a39258bbab67784e9743de9 (patch)
treea01224b54f5a3d37f2aadf130450313c01656872 /src/CMakeLists.txt
parente487737b4fb7267385d8219796263ef29c3b9b95 (diff)
downloadhdf5-ff490b4a69029fa75a39258bbab67784e9743de9.zip
hdf5-ff490b4a69029fa75a39258bbab67784e9743de9.tar.gz
hdf5-ff490b4a69029fa75a39258bbab67784e9743de9.tar.bz2
Add 'blob' callbacks to VOL, along with a native implementation to store them
in the global heap, and changed the VL datatype conversion code to use blobs. Move encode/decode of sequence lengths into VL datatype callbacks, from native VOL blob routines.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6df8af3..b50fa71 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -649,6 +649,7 @@ set (H5VL_SOURCES
${HDF5_SRC_DIR}/H5VLint.c
${HDF5_SRC_DIR}/H5VLnative.c
${HDF5_SRC_DIR}/H5VLnative_attr.c
+ ${HDF5_SRC_DIR}/H5VLnative_blob.c
${HDF5_SRC_DIR}/H5VLnative_dataset.c
${HDF5_SRC_DIR}/H5VLnative_datatype.c
${HDF5_SRC_DIR}/H5VLnative_file.c