summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2021-05-04 20:51:26 (GMT)
committerGitHub <noreply@github.com>2021-05-04 20:51:26 (GMT)
commitdbe7204085d46188414fd9d9e0dde48afcf30f28 (patch)
tree1a46a7ff0f36556da8ef551c1d31540f0e4e1a15 /src/CMakeLists.txt
parentc7d45c205e78f141df76578ed72243d4445ac675 (diff)
downloadhdf5-dbe7204085d46188414fd9d9e0dde48afcf30f28.zip
hdf5-dbe7204085d46188414fd9d9e0dde48afcf30f28.tar.gz
hdf5-dbe7204085d46188414fd9d9e0dde48afcf30f28.tar.bz2
Hash table replacement for skip lists in ID code (#600)
* Committing clang-format changes * Brings over hash table code from Bitbucket * Can be switched between skip list and hash table implementation with H5_USE_ID_HASH_TABLE #define * Not yet updated to use iterate-safe delete * Fixes a warning and changes where the problematic test is commented out. * Adds mark-and-sweep flags and members * Final fixes for hash table ID code * Removes skip list ID code * Committing clang-format changes * Formatted source * Adds a comment about the mark-and-sweep scheme. Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0d2d960..9bacd6b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -971,6 +971,8 @@ set (H5_PRIVATE_HEADERS
${HDF5_SRC_DIR}/H5Zprivate.h
${HDF5_SRC_DIR}/H5win32defs.h
+
+ ${HDF5_SRC_DIR}/uthash.h
)
set (H5_GENERATED_HEADERS